Bug 46689 - hang on mount /mnt/cdrom w/ 2.4.3-12
Summary: hang on mount /mnt/cdrom w/ 2.4.3-12
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-29 19:45 UTC by Zing
Modified: 2007-04-18 16:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 14:09:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zing 2001-06-29 19:45:34 UTC
Description of Problem:
After upgrading RH7.1 to kernel 2.4.3-12 i686, mount /mnt/cdrom will 
spit out: (note: typed by hand...)

hdc: set_drive_speed_status: status=0x51 { DriveReady SeekComplete Error }
hdc: set_drive_speed_status: error=0x64
hdc:ATAPI 40x CD-ROM DRIVE, 128kB Cache, DMA

and machine will hang, cannot switch consoles or ctl-alt-del.

Prior kernel 2.4.2-2 would spit out:

hdc: (U)DMA disabled and continue on with mount.  booting 2.4.3-12 with
ide=nodma mounts the cd-rom without hang.  

cat /proc/ide/hdc/model  is CRD-8400B.

Machine is IBM NetVista TYPE 6578-LAU

How Reproducible:

always

Steps to Reproduce:
1. mount /mnt/cdrom 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Arjan van de Ven 2001-07-02 08:41:45 UTC
I've added this to the "no dma" blacklist
You can use hdparm to disable DMA only on the cdrom while keeping dma
on your harddisks btw.

Comment 2 Zing 2001-07-02 19:17:30 UTC
Thanks.

Comment 3 Neil Simmonds 2001-07-21 01:30:59 UTC
I have the same model and cannot do anything to the CD without hanging.
Even hdparm -d0 /dev/cdrom hangs.

Comment 4 Hannu Martikka 2001-09-18 09:25:41 UTC
Same problem shows up on IBM mPro 6868-30G (6868 was supposed to be certified
by RedHat for RH-7.1...)

Cdrom is CRD-8480C

Btw. After I turned dma off something turned it back on.. You'd better also
set the "keep settings" option. I use -u1 -d0 -c3 -k1 


Comment 5 Bryce Nesbitt 2002-01-31 14:05:30 UTC
This one needs to be on the dma blacklist also:
	HardHat:bryce> cat /proc/ide/hda/model
	SONY CD-RW CRX140E
	Firmware 1.0n
DMA for this drive does not work under windows either.  On RH7.2 mounting with
DMA
on locks the machine.  Using hdparm to turn dma off fixes it.

Too bad, since this drive was "recommended" for Linux use.


Note You need to log in before you can comment on or make changes to this bug.