Bug 4669 - bad include file: glib.h
Summary: bad include file: glib.h
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-23 16:09 UTC by signal11
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-23 18:31:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description signal11 1999-08-23 16:09:46 UTC
including glib.h will fail during compilation because it
expects glibconfig.h to be in the standard include
directory.

change line 66 from:
#include <glibconfig.h>
to:
#include <"/usr/lib/glib/include/glibconfig.h">

-OR-
ln -s /usr/lib/glib/include/glibconfig.h /usr/include

Comment 1 Bill Nottingham 1999-08-23 18:31:59 UTC
BTW, the component would be gtk+, not glibc.

If you use 'glib-config --cflags' in your CFLAGS, this won't
happen.


Note You need to log in before you can comment on or make changes to this bug.