Bug 466924 - rpm -V openldap complains
rpm -V openldap complains
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openldap (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Zeleny
Ondrej Moriš
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 10:57 EDT by Petr Sklenar
Modified: 2012-10-15 04:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: openldap-2.3.43-3.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1230263 (view as bug list)
Environment:
Last Closed: 2010-07-02 15:39:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2008-10-14 10:57:16 EDT
Description of problem:
"rpm -V openldap" complains about wrong links:
....L...   /usr/lib64/liblber-2.3.so.0
....L...   /usr/lib64/libldap-2.3.so.0
....L...   /usr/lib64/libldap_r-2.3.so.0

Version-Release number of selected component (if applicable):
openldap-2.3.43-2.el5

How reproducible:
always

Steps to Reproduce:
1. rpm -V openldap
....L...   /usr/lib/liblber-2.3.so.0
....L...   /usr/lib/libldap-2.3.so.0
....L...   /usr/lib/libldap_r-2.3.so.0

  
Actual results:
rpm -V complains

Expected results:
rpm -V has no complains

Additional info:
It couldn't be fix in version of rhel5U3, there is risk of lower compatibility, see https://bugzilla.redhat.com/show_bug.cgi?id=460307#c4
Comment 2 Jan Zeleny 2009-06-18 07:11:28 EDT
Package was tested in both RHEL 5.3 and Fedora rawhide and there is no sign of issue persisting in current releases of openldap. Changing state to modified.
Comment 3 releng-rhel@redhat.com 2009-10-29 15:19:56 EDT
Fixed in 'openldap-2.3.43-3.el5'. 'openldap-2.4.16-2.el6' included in compose 'RHEL6.0-20091028.0'.
Moving to ON_QA.
Comment 4 Ondrej Moriš 2010-03-30 06:38:21 EDT
I've tried to verify this bug, but there is still some complaint on RHEL5. Moreover the reported bug is reproducible on RHEL6. 

RHEL5-U4 (openldap-2.3.43-3.el5):

S.5.....  c /etc/openldap/ldap.conf

RHEL6 (openldap-2.4.19-7.el6)

S.5....T.  c /etc/openldap/ldap.conf
....L....    /usr/lib64/liblber-2.4.so.2
....L....    /usr/lib64/libldap-2.4.so.2
....L....    /usr/lib64/libldap_r-2.4.so.2
Comment 5 Ondrej Moriš 2010-04-05 18:47:46 EDT
However there were some problems when upgrading RHEL6-Alpha-3 to the latest RHEL6, everything seems to be correct when upgrading from RHEL6-Beta-1 and therefore I'm setting verified field to PreBeta (still ON_QA) for now, i.e. bug is verified for Beta but we need it to be verified on RC.
Comment 6 Ondrej Moriš 2010-04-12 06:57:35 EDT
Well, rpm -V still complains with "S.5....T.  c /etc/openldap/ldap.conf" on openldap-2.4.19-7.el6 / RHEL6.0-20100408.0. However, it is another thing (maybe a problem) and since reported problem is fixed I consider provided patch as successfully verified. 

RHTS test has been proposed (see QA Whiteboard), it ignores all configuration files complaints for now (to PASS).
Comment 7 releng-rhel@redhat.com 2010-07-02 15:39:11 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.