Bug 466925 - NM is inconsistently able to find non-broadcasting SSIDs
NM is inconsistently able to find non-broadcasting SSIDs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ipw3945-kmod (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jon Masters
desktop-bugs@redhat.com
: Desktop
Depends On:
Blocks: 466938
  Show dependency treegraph
 
Reported: 2008-10-14 11:01 EDT by Suzanne Hillman
Modified: 2009-01-20 16:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:55:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Scan capability advertisement patch for ipw3945 against RHEL 5.3 kernel (494 bytes, text/plain)
2008-11-06 10:08 EST, Dan Williams
no flags Details
Updated patch; ipw3945 only supports SSID scans (474 bytes, patch)
2008-11-06 10:14 EST, Dan Williams
no flags Details | Diff

  None (edit)
Description Suzanne Hillman 2008-10-14 11:01:55 EDT
Description of problem:
NM is inconsistently able to find non-broadcasting SSIDs. I think this used to work more often than I'm seeing it work now, and it's happening on more than one network card.

Version-Release number of selected component (if applicable):
NM-0.7.0-0.11.svn4133.el5

How reproducible:
Pretty often.

Steps to Reproduce:
1. Try to connect to a WAP which is not broadcasting its SSID and to which NM has not already connected.
  
Actual results:
Generally will fail to connect.

Expected results:
Should find it!

Additional info:
Comment 1 Dan Williams 2008-10-15 15:32:06 EDT
This is with ipw3945, right?

Solution for this is to add scan capabilties to ipw3945 so we can actually probe-scan the stupid hidden APs...  It's a 1 line patch:

   range->scan_capa = IW_SCAN_CAPA_ESSID;

We added scan capabilties in 5.2 but didn't patch the out-of-tree drivers that were capable of doing probe-scans, which was basically just ipw3945.  mac80211, ipw2200, and hostap have been running with these patches since 5.2 got released.

They enable NM to direct the driver to probe-scan the AP and thus discover the hidden APs much more easily since they don't normally show up in scans in any useful manner without being probed.
Comment 2 Dan Williams 2008-10-15 15:34:14 EDT
This is pretty easy to test and a very low-risk change because:

1) the patch is informational only, it simply adds a capability
2) the only consumer of this capability in the distro right now is NetworkManager
3) we added scan capabilties for other drivers back in 5.2
4) does _not_ require any additional driver or wpa_supplicant testing
Comment 3 Dan Williams 2008-10-15 15:40:31 EDT
See also:

https://bugzilla.redhat.com/show_bug.cgi?id=466938

which is almost definitely the same problem.
Comment 4 Suzanne Hillman 2008-10-16 11:44:08 EDT
Yes, this was with ipw3945, but I think it wasn't the only one having that problem.
Comment 7 Dan Williams 2008-11-06 10:08:09 EST
Created attachment 322735 [details]
Scan capability advertisement patch for ipw3945 against RHEL 5.3 kernel

#ifdef check is for WE >= 20 becuase that's what current RHEL kernels advertise.
Comment 8 Dan Williams 2008-11-06 10:14:10 EST
Created attachment 322738 [details]
Updated patch; ipw3945 only supports SSID scans
Comment 12 Zack Cerza 2008-12-19 13:18:57 EST
I haven't been able to reproduce this. Suzanne, are you able to retest?
Comment 13 Suzanne Hillman 2008-12-19 23:24:59 EST
With NM-0.7.0-2.el5, Converse, ipw3945, attempting to connect to a hidden SSID using WPA2 and requiring MAC addresses to be in a known list fails. When it asks me to re-enter the security information, even though I specified WPA2 initially, it doesn't even give me the option of WPA at _all_, which means that I do not know if it would work if it tried a second time. I know my passphrase is right, as is the protocol. This appears to not be fixed.

It worked fine before I disabled SSID broadcast, so that is the only difference.

I believe that this is snap 5, although I'm completely unsure as I've been very sick with a flu for weeks now.
Comment 21 errata-xmlrpc 2009-01-20 16:55:15 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0243.html

Note You need to log in before you can comment on or make changes to this bug.