This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 466992 - NFS-ISO installs fail in Fedora 10 Beta
NFS-ISO installs fail in Fedora 10 Beta
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Bryan Stillwell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 18:16 EDT by Bryan Stillwell
Modified: 2008-11-05 16:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 13:07:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Stillwell 2008-10-14 18:16:16 EDT
Description of problem:
I'm trying to install Fedora 10 Beta using the NFS-ISO method and the install fails with:

   That directory could not be mounted from the server


I started off trying the cmdline option that I know works on Fedora 5-9:

   method=nfs:iso.test:/rbfd/iso/fedora/betas/10b1/x86_64/


However, I saw in some of the logs that 'method' is deprecated, so I also tried the following without success:

   repo=nfsiso:iso.test:/rbfd/iso/fedora/betas/10b1/x86_64/


Version-Release number of selected component (if applicable):
Anaconda 11.4.1.40
Linux 2.6.27-0.352.rc7.git1.fc10.x86_64

How reproducible: Every time


Steps to Reproduce:
1. Install Fedora 10 (Beta 1) on an HP DL380G5 by using a nfsiso repo
2. Watch it fail to start the second stage of the install

  
Actual results:

Some key log messages on tty3:
22:03:29 INFO    : anaconda version 11.4.1.40 on x86_64 starting
22:03:29 INFO    : 8073100 kB are available
FATAL: Module loop not found.
FATAL: Error inserting floppy (/lib/modules/2.6.27-0.352.rc7.git1.fc10.x86_64/kernel/drivers/block/floppy.ko.gz): No such device
FATAL: Module ext3 not found.
22:03:34 INFO    : trying to mount CD device /dev/sr0 on /mnt/stage2
22:04:50 INFO    : no stage2= given, assuming nfsiso:iso.test:/rbfd/iso/fedora/betas/10b1/x86_64//images/install.img


Expected results:
To be able to install using ISO images over NFS

Additional info:
When the installer first boots up it waits for a while (> 10secs) with this message:

   Looking for installation images on CD device /dev/sr0

Since we're doing an nfs-iso install, it should skip the test for the CD...  I'm putting this in here instead of filing a new bug because I believe the two problems are likely related to each other.
Comment 1 Chris Lumens 2008-10-15 13:07:26 EDT
Everything you're seeing here is intentional.  What's going on is that the loader is looking for the install.img file and you haven't told it where it is via the stage2= parameter.  Thus loader goes out looking for it in this order:

(1) Try to find it via stage2=, then
(2) Look for it on any attached CDs, then
(3) Infer a location based on method= or repo=.  That's what you are seeing in the log file.

Additionally there's been a slight change in NFSISO as well where we no longer look inside the ISO images for the install.img.  It now needs to be located elsewhere.  You can either boot up with the boot.iso to provide the install.img or you can place it in images/ at the same directory level as your ISO images.
Comment 2 Nils Philippsen 2008-11-04 08:11:46 EST
(In reply to comment #1)
> Additionally there's been a slight change in NFSISO as well where we no longer
> look inside the ISO images for the install.img.  It now needs to be located
> elsewhere.  You can either boot up with the boot.iso to provide the install.img
> or you can place it in images/ at the same directory level as your ISO images.

Can you tell me why it is this way? Have there been unsurmountable problems with using the images.img from the ISOs contained in the NFS directory?
Comment 3 Chris Lumens 2008-11-05 16:23:39 EST
(In reply to comment #2)
> Can you tell me why it is this way? Have there been unsurmountable problems
> with using the images.img from the ISOs contained in the NFS directory?

No, there weren't insurmountable problems.  However, we are trying to separate the install.img and the packages to be installed more.  The reason for this is so anaconda is not tied so tightly to installing any particular version of a product.  In order to reinforce this idea a little, we've done things like add the repo= and stage2= parameters, make the loader only look for install.img instead of also validating the repo, and not look inside ISO images for the install.img.

Note You need to log in before you can comment on or make changes to this bug.