Bug 466998 - Attempting to go fullscreen with Flash crashes it.
Attempting to go fullscreen with Flash crashes it.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 20:46 EDT by Gideon Mayhak
Modified: 2008-10-16 20:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 20:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gideon Mayhak 2008-10-14 20:46:45 EDT
Description of problem:
In Fedora 10 Beta/rawhide (latest updates installed) x86_64, Flash performance is generally poor and fullscreen playback does not work (the area of the Flash player goes gray).  I have both x86_64 and i386 nspluginwrapper packages installed, including their dependencies.  This occurs with both Flash 9 and the latest 10 RC.

Version-Release number of selected component (if applicable):
[gideon@gidux-laptop-rawhide ~]$ yum list installed | grep i386
atk.i386                                 1.24.0-1.fc10          installed       
cairo.i386                               1.8.0-1.fc10           installed       
cups-libs.i386                           1:1.3.9-1.fc10         installed       
cyrus-sasl-lib.i386                      2.1.22-19.fc10         installed       
db4.i386                                 4.7.25-5.fc10          installed       
e2fsprogs-libs.i386                      1.41.3-1.fc10          installed       
expat.i386                               2.0.1-5                installed       
flash-plugin.i386                        10.0.12.10-release     installed       
fontconfig.i386                          2.6.0-2.fc10           installed       
freetype.i386                            2.3.7-1.fc10           installed       
gamin.i386                               0.1.9-6.fc10           installed       
glib2.i386                               2.18.1-2.fc10          installed       
glibc.i386                               2.8.90-13              installed       
gnutls.i386                              2.4.2-2.fc10           installed       
gtk2.i386                                2.14.3-6.fc10          installed       
jasper-libs.i386                         1.900.1-8.fc9          installed       
keyutils-libs.i386                       1.2-3.fc9              installed       
krb5-libs.i386                           1.6.3-16.fc10          installed       
libICE.i386                              1.0.4-4.fc10           installed       
libSM.i386                               1.1.0-2.fc10           installed       
libX11.i386                              1.1.4-4.fc10           installed       
libXau.i386                              1.0.4-1.fc10           installed       
libXcomposite.i386                       0.4.0-5.fc10           installed       
libXcursor.i386                          1.1.9-3.fc10           installed       
libXdamage.i386                          1.1.1-4.fc9            installed       
libXdmcp.i386                            1.0.2-6.fc10           installed       
libXext.i386                             1.0.4-1.fc9            installed       
libXfixes.i386                           4.0.3-4.fc10           installed       
libXft.i386                              2.1.13-1.fc10          installed       
libXi.i386                               1.1.3-4.fc9            installed       
libXinerama.i386                         1.0.3-2.fc10           installed       
libXrandr.i386                           1.2.3-1.fc10           installed       
libXrender.i386                          0.9.4-3.fc9            installed       
libXt.i386                               1.0.5-1.fc10           installed       
libcurl.i386                             7.18.2-7.fc10          installed       
libgcc.i386                              4.3.2-6                installed       
libgcrypt.i386                           1.4.3-1.fc10           installed       
libgpg-error.i386                        1.6-2                  installed       
libidn.i386                              0.6.14-8               installed       
libjpeg.i386                             6b-43.fc10             installed       
libpng.i386                              2:1.2.31-2.fc10        installed       
libselinux.i386                          2.0.73-1.fc10          installed       
libssh2.i386                             0.18-7.fc9             installed       
libstdc++.i386                           4.3.2-6                installed       
libtasn1.i386                            1.5-1.fc10             installed       
libthai.i386                             0.1.9-4.fc9            installed       
libtiff.i386                             3.8.2-11.fc10          installed       
libxcb.i386                              1.1.91-4.fc10          installed       
ncurses-libs.i386                        5.6-20.20080927.fc10   installed       
nspluginwrapper.i386                     1.1.0-11.fc10          installed       
nspr.i386                                4.7.1-5.fc10           installed       
nss.i386                                 3.12.1.1-3.fc10        installed       
openldap.i386                            2.4.11-3.fc10          installed       
openssl.i386                             0.9.8g-11.fc10         installed       
pango.i386                               1.22.0-1.1.fc10        installed       
pixman.i386                              0.12.0-1.fc10          installed       
readline.i386                            5.2-13.fc9             installed       
sqlite.i386                              3.5.9-2.fc10           installed       
zlib.i386                                1.2.3-18.fc9           installed       
[gideon@gidux-laptop-rawhide ~]$ yum list installed | grep nspluginwrapper.x86_64
nspluginwrapper.x86_64                   1.1.0-11.fc10          installed       

How reproducible:
Every time I try to go fullscreen with a Flash video (on YouTube or Hulu or similar).

Steps to Reproduce:
1. Install Fedora 10 Beta/rawhide x86_64
2. Install nspluginwrapper.i386 and its dependencies
3. Install either the latest stable Flash 9 or the latest Flash 10 RC
4. Go to YouTube or Hulu and play a video
5. Click the button to go fullscreen
  
Actual results:
Gray screen where the Flash video is/was.

Expected results:
Go fullscreen and play like it does under Fedora 9 i386.

Additional info:
I haven't tried installing firefox.i386, because it is not available in the x86_64 rawhide repo.  If it was available and it worked, I would be willing to downgrade.  However, I'd prefer to run as little i386 software as possible, as I'd like to move to x86_64 altogether.  Am I doing something wrong?  Do I need to install something else?
Comment 1 Gideon Mayhak 2008-10-15 18:55:15 EDT
I guess I should also note I am using the proprietary NVIDIA drivers with TwinView.  Here is my xorg.conf:

--------------------
[gideon@gidux-laptop-rawhide ~]$ cat /etc/X11/xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder58)  Wed Oct  1 15:13:37 PDT 2008

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Wed Oct  1 15:12:53 PDT 2008

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "pc105"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "SONY CPD-G400"
    HorizSync       30.0 - 107.0
    VertRefresh     48.0 - 120.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce Go 6100"
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0, CRT: 1280x960 +1280+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "CRT: 1280x960_60 +1280+0, DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
--------------------

I'm using almost the exact same setup in Fedora 9 and I can go fullscreen (although, it always go to the leftmost screen, even when Firefox is on the rightmost).  I also just installed the i386 PulseAudio libs to get sound, but that made no change to the fullscreen issue.
Comment 2 Gideon Mayhak 2008-10-15 18:55:57 EDT
And I just updated to the stable Flash 10 release on both Fedora 9 and 10 Beta/rawhide with no change.
Comment 3 Gideon Mayhak 2008-10-16 19:49:24 EDT
If I do not have my external monitor connected (so that it's just my laptop display), I can go fullscreen with Flash.  This seems to be an incompatibility between Flash and TwinView, though it does work fine under Fedora 9 32-bit.  Is there anything I can try to get it working under rawhide x86_64?  At this rate, I may give up on 64-bit until Fedora 11 (it's not like I *need* it, but I'd like to fully utilize my available hardware).
Comment 4 Gideon Mayhak 2008-10-16 20:11:32 EDT
Umm, nevermind?  I'm sorry, but I redid my settings in nvidia-settings and it's now working the same as in Fedora 9.  I'm sorry for bothering you.  Who knows what happened, but it's working now.

Note You need to log in before you can comment on or make changes to this bug.