This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 467002 - Syntax error in check_linux_raid causes the script to always fail
Syntax error in check_linux_raid causes the script to always fail
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: nagios-plugins (Show other bugs)
el5
All Linux
medium Severity low
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 22:32 EDT by Kel Raywood
Modified: 2010-05-11 12:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.4.13-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-11 12:03:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kel Raywood 2008-10-14 22:32:22 EDT
Description of problem:

Syntax error in check_linux_raid causes the script to always fail.  There is a missing semi-colon at the end of line 26 of

    %{libdir}/nagios/plugins/check_linux_raid

Version-Release number of selected component (if applicable):
nagios-plugins-linux_raid-1.4.13-4.el5

How reproducible: Always

Steps to Reproduce:
1. yum install nagios-plugins-linux_raid
2. /usr/lib/nagios/plugins/check_linux_raid
  
Actual results:

"use" not allowed in expression at /usr/lib/nagios/plugins/check_linux_raid line 27, at end of line
syntax error at /usr/lib/nagios/plugins/check_linux_raid line 27, near "use utils "
Execution of /usr/lib/nagios/plugins/check_linux_raid aborted due to compilation errors.

Expected results:

OK md0 status=[UU]. md1 status=[UU]. md2 status=[UU].


Additional info:

The following patch fixes the problem

--- /usr/lib/nagios/plugins/check_linux_raid.ORIG       2008-09-28 21:42:00.000000000 -0700
+++ /usr/lib/nagios/plugins/check_linux_raid    2008-10-14 19:00:54.000000000 -0700
@@ -23,7 +23,7 @@
 #        WARNING md0 status=[UUU_U], recovery=46.4%, finish=123.0min
 
 use strict;
-use lib "/usr/lib/nagios/plugins"
+use lib "/usr/lib/nagios/plugins";
 use utils qw(%ERRORS);
 
 # die with an error if we're not on Linux
Comment 1 Kel Raywood 2010-05-11 12:03:37 EDT
This bug was fixed in Oct, 2008 at version 1.4.13-5.
This bug has been resolved.

Note You need to log in before you can comment on or make changes to this bug.