Bug 467007 - NetworkManager-pptp broken since Oct 11 updates
NetworkManager-pptp broken since Oct 11 updates
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager-pptp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-14 23:15 EDT by Michel Alexandre Salim
Modified: 2013-01-09 23:51 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 14:00:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2008-10-14 23:15:12 EDT
Description of problem:
The update to NetworkManager breaks pptp support somehow; now it just shows the "connecting" icon endlessly, without actually connecting or timing out.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.11.svn4175.fc10.x86_64
NetworkManager-pptp-0.7.0-0.11.svn4178.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Set up a PPTP VPN
2. Try to connect
3. ps auxwww | grep pptp
  
Actual results:
No connection ever brought up; the underlying connection still works. 'ps' shows that pptp is not started, but the following processes are running:

root /usr/libexec/nm-pptp-service state: S
user /usr/libexec/nm-pptp-auth-dialog -u <some-uid> -n <VPN-name> -s org.freedesktop.NetworkManager.pptp state: SL

Killing the user process aborts the connection attempt.

Expected results:
Connection should just work; used to before the update (that ironically is PPTP-related!)


Additional info:
Connection details: allowable protocol MS-CHAP v2, and when it was working with NM-PPTP, I had to toggle on MPPE for the connection to work. Disabling SELinux does not make any difference.
Comment 1 John Poelstra 2008-10-17 19:25:16 EDT
Can you provide any logs or information from /var/log/messages?
Comment 2 Dan Williams 2008-10-27 23:25:48 EDT
How about with NM svn4201 and latest PPTP plugin?
Comment 3 Dan Williams 2008-10-28 23:48:43 EDT
Nevermind, found the cause, terribly sorry, will push out a .1 update for the pptp plugin tomorrow.
Comment 4 Dan Williams 2008-10-28 23:49:02 EDT
clear needinfo
Comment 6 Jesse Keating 2008-10-29 23:42:46 EDT
Re-opening until it actually gets tagged for the release.  https://fedoraproject.org/wiki/ReleaseEngineering/FinalFreezePolicy
Comment 7 Bill Nottingham 2008-11-04 14:00:29 EST
Appears to be tagged and in the release now.
Comment 8 Fedora Update System 2008-11-23 18:05:16 EST
NetworkManager-0.7.0-0.12.svn4326.fc9,NetworkManager-vpnc-0.7.0-0.11.svn4326.fc9,NetworkManager-openvpn-0.7.0-16.svn4326.fc9,NetworkManager-pptp-0.7.0-0.12.svn4326.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0-0.12.svn4326.fc9,NetworkManager-vpnc-0.7.0-0.11.svn4326.fc9,NetworkManager-openvpn-0.7.0-16.svn4326.fc9,NetworkManager-pptp-0.7.0-0.12.svn4326.fc9
Comment 9 Fedora Update System 2008-11-23 18:07:35 EST
NetworkManager-0.7.0-0.12.svn4326.fc8,NetworkManager-vpnc-0.7.0-0.11.svn4326.fc8,NetworkManager-openvpn-0.7.0-16.svn4326.fc8,NetworkManager-pptp-0.7.0-0.12.svn4326.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0-0.12.svn4326.fc8,NetworkManager-vpnc-0.7.0-0.11.svn4326.fc8,NetworkManager-openvpn-0.7.0-16.svn4326.fc8,NetworkManager-pptp-0.7.0-0.12.svn4326.fc8
Comment 10 Fedora Update System 2008-12-21 18:37:46 EST
NetworkManager-0.7.0-0.12.svn4326.fc9, NetworkManager-vpnc-0.7.0-0.11.svn4326.fc9, NetworkManager-openvpn-0.7.0-16.svn4326.fc9, NetworkManager-pptp-0.7.0-0.12.svn4326.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-12-21 18:42:48 EST
NetworkManager-0.7.0-0.12.svn4326.fc8, NetworkManager-vpnc-0.7.0-0.11.svn4326.fc8, NetworkManager-openvpn-0.7.0-16.svn4326.fc8, NetworkManager-pptp-0.7.0-0.12.svn4326.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.