Bug 467018 - cant switch x11 keyboard layout
cant switch x11 keyboard layout
Status: CLOSED DUPLICATE of bug 466675
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 04:00 EDT by Roman Makurin
Modified: 2015-01-14 18:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 03:53:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Makurin 2008-10-15 04:00:02 EDT
Description of problem:
Can`t switch x11 keyboard layout. According to Xorg.0.log and lshal output everything is OK.

How reproducible:
Always

Steps to Reproduce:
1. Install fedora rawhide(10_beta)
2. Choose Russian keyboard layout in system-config-keyboard
3. reboot
4. Login to Gnome Session - there is no Russian keyboard layout at all
  
Actual results:
Can`t input russian texts

Additional info:

Here is information from hal about keyboard settings:

udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'
  info.subsystem = 'input'  (string)
  input.xkb.model = 'pc105'  (string)
  info.product = 'AT Translated Set 2 keyboard'  (string)
  input.keymap.data = { 'e001:fn_esc', 'e009:battery', 'e00a:screenlock', 'e00b:camera', 'e00c:media', 'e00e:dvd', 'e031:help', 'e033:f21', 'e057:wlan', 'e008
:player', 'e058:f22', 'e059:f23' } (string list)
  input.xkb.layout = 'us,ru'  (string)
  info.category = 'input'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'  (string)
  input.xkb.options = 'grp:shifts_toggle,grp_led:scroll'  (string)
  input.x11_driver = 'evdev'  (string)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio0/input/input5/event5'  (string)
  input.device = '/dev/input/event5'  (string)
  info.callouts.add = { 'hal-setup-keymap', 'fedora-setup-keyboard' } (string list)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'input.keymap', 'button' } (string list)
  input.product = 'AT Translated Set 2 keyboard'  (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  info.addons.singleton = { 'hald-addon-input' } (string list)
  linux.subsystem = 'input'  (string)
  linux.device_file = '/dev/input/event5'  (string)
  input.xkb.rules = 'base'  (string)

I found that fedora-setup-keyboard used as hal hook to set up layouts. When I`m trying to use custom xkb settings:

1) # chmod -x /usr/bin/fedora-setup-keyboard

 and put following *.fdi file

2) # cat /etc/hal/fdi/policy/x11-input.fdi
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
<device>
<match key="info.capabilities" contains="input.keyboard">
<merge key="input.xkb.layout" type="string">us,ru</merge>
<merge key="input.xkb.options" type="string">grp:alt_shift_toggle,grp_led:scroll</merge>
</match>
</device>
</deviceinfo>

Here is Xorg.0.log

(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) AT Translated Set 2 keyboard: xkb_rules: "evdev"
(**) Option "xkb_model" "pc105"
(**) AT Translated Set 2 keyboard: xkb_model: "pc105"
(**) Option "xkb_layout" "us,ru"
(**) AT Translated Set 2 keyboard: xkb_layout: "us,ru"
(**) Option "xkb_options" "grp:alt_shift_toggle,grp_led:scroll"
(**) AT Translated Set 2 keyboard: xkb_options: "grp:alt_shift_toggle,grp_led:scroll"

But Alt+Shift switch doesn`t work - only US layout available

PS: Sorry for my English
Comment 1 Peter Hutterer 2008-10-16 02:23:15 EDT
When you click on your name in GDM, you can see a keyboard layout selector at the bottom of the screen. Is this set to US?
Comment 2 Roman Makurin 2008-10-16 03:16:10 EDT
> Is this set to US?

Yes it is.
Comment 3 Peter Hutterer 2008-10-16 03:53:41 EDT
Changing that to your preferred layout should fix it.

Marking as duplicate of Bug 466675.

*** This bug has been marked as a duplicate of bug 466675 ***

Note You need to log in before you can comment on or make changes to this bug.