Bug 467042 - nspluginwrapper doesn't work well with flash-plugin-10.0.12.36
nspluginwrapper doesn't work well with flash-plugin-10.0.12.36
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 08:48 EDT by Mads Kiilerich
Modified: 2008-10-23 12:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 12:34:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2008-10-15 08:48:04 EDT
Description of problem:

Flash sucks, but we all (?) need and love nspluginwrapper for making it suck less.

With the lastest update of flash-plugin from adobe yum repo it doesn't work as good as before.

When starting firefox in foreground it prints out stdout:
c/npw-viewer.c:3065../src/npw-viewer.c:3067../src/npw-wrapper.c:1912../src/npw-wrapper.c:1864../src/npw-viewer.c:3033../src/npw-viewer.c:3025../src/npw-viewer.c:3027../src/npw-wrapper.c:1866../src/npw-wrapper.c:1910../src/npw-viewer.c:3065../src/npw-viewer.c:3067../src/npw-wrapper.c:1912../src/npw-wrapper.c:1864../src/npw-viewer.c:3033../src/npw-viewer.c:3025../src/npw-viewer.c:3027../src/npw-wrapper.c:1866../src/npw-wrapper.c:1910../src/npw-viewer.c:3065../src/npw-viewer.c:3067../src/npw-wrapper.c:1912../src/npw-wrapper.c:1777../src/npw-viewer.c:2992../src/npw-viewer.c:2974../src/npw-viewer.c:2976../src/npw-wrapper.c:1779../src/npw-wrapper.c:1446../src/npw-viewer.c:1195../src/npw-viewer.c:1198../src/npw-viewer.c:687../src/npw-viewer.c:2680../src/npw-viewer.c:1647../src/npw-viewer.c:1649../src/npw-viewer.c:2682../src/npw-wrapper.c:1448../src/npruntime.c:84../src/npruntime.c:86../src/npw-wrapper.c:2653../src/npw-viewer.c:2562../src/npw-viewer.c:2548../src/npw-viewer.c:2550../src/npw-wrapper.c:2891../src/npw-viewer.c:3375*** NSPlugin Viewer  *** ERROR: NPN_GetURLNotify() invoke: Connection closed
../src/npw-viewer.c:689../src/npw-wrapper.c:2663../src/npw-wrapper.c:2891
...
*** NSPlugin Wrapper *** ERROR: NPObject 0xf616358 is not valid!
*** NSPlugin Wrapper *** ERROR: NPObject 0xf616358 is not valid!
../src/npw-wrapper.c:1495*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
../src/npw-wrapper.c:1497../src/npw-wrapper.c:2025*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
../src/npw-wrapper.c:2027../src/npw-wrapper.c:2025*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
../src/npw-wrapper.c:2027*** NSPlugin Wrapper *** ERROR: NPObject 0xf616358 is not valid!
*** NSPlugin Wrapper *** ERROR: NPObject 0xf616358 is not valid!
*** NSPlugin Wrapper *** ERROR: NPObject 0xf616358 is not valid!
*** NSPlugin Wrapper *** ERROR: NPObject 0xf616358 is not valid!
../src/npw-wrapper.c:2025*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
../src/npw-wrapper.c:2027*** NSPlugin Wrapper *** ERROR: NPObject 0xf616358 is not valid!
*** NSPlugin Wrapper *** ERROR: NPObject 0xf616358 is not valid!
*** NSPlugin Wrapper *** ERROR: NPObject 0xf616358 is not valid!

And firefox seems to crash more often.


Version-Release number of selected component (if applicable):
nspluginwrapper-1.1.0-11.fc10.i386
flash-plugin-10.0.12.36-release.i386
libflashsupport-000-0.5.svn20070904.i386


Additional info:

Like it or not, if this is a general problem then I think this is a f10 blocker :-(
Comment 1 Martin Stransky 2008-10-22 06:52:34 EDT
please check the updated rawhide package (1.1.2-3)
Comment 2 Christopher D. Stover 2008-10-23 12:31:43 EDT
Did the new version fix your problem Mads?
Comment 3 Mads Kiilerich 2008-10-23 12:34:17 EDT
I am testing right now, and yes, it seems to work just fine. Thanks! 

I am running without libflashsupport as recommended by wwoods. I don't know if that makes the test more or less trustworthy ...

Closing.
Comment 4 Mads Kiilerich 2008-10-23 12:47:17 EDT
By the way, I notice that when playing from myspace then I get something like

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 6624 mk        20   0  375m 239m  22m S 22.5 11.8   5:49.66 firefox
 7123 mk        20   0  241m  48m  12m R 15.9  2.4   1:37.73 npviewer.bin
 6477 mk         9 -11  160m 6308 5136 S  3.6  0.3   0:31.32 pulseaudio

I would expect flash to run in npviewer.bin, and it doesn't seem reasonable that firefox uses that much cpu doing nothing.

Is that worth following up on?

Note You need to log in before you can comment on or make changes to this bug.