Bug 467140 - KDE package group (kde-desktop) not complete
KDE package group (kde-desktop) not complete
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 18:21 EDT by Γριφεγ Γ.
Modified: 2014-03-16 23:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 14:17:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Γριφεγ Γ. 2008-10-15 18:21:44 EDT
Description of problem:
KDE Fedora 10 Beta LiveCD installs stuff like Filelight and KOffice, which are in turn not in kde-desktop group, and so not removed when the user decides to get rid of KDE.
Comment 1 Rex Dieter 2008-10-16 08:00:03 EDT
Your expectation that the livecd contents exactly match comps' definition of kde-desktop is incorrect.
Comment 2 Γριφεγ Γ. 2008-10-16 08:49:53 EDT
That's totally not what I said.
Comment 3 Rex Dieter 2008-10-16 09:04:27 EDT
So what is your expectation here?

Every (kde) application on the kde live image be in the kde-desktop group (as default?), right?

Because, as far as know, comps groups are really to help *installing* things, using them to uninstall items is problematic (ie, there's some overlap between, say kde-desktop and gnome-desktop for example).
Comment 4 Kevin Kofler 2008-10-16 09:08:12 EDT
"yum remove kdelibs-common" is the most effective way to remove all KDE stuff.
If you remove only the kde-desktop group, you're missing kdelibs-common and kdelibs3, so some KDE 3 apps stay.
"yum groupremove" almost never does what you want.
Comment 5 Γριφεγ Γ. 2008-10-16 13:35:17 EDT
OK, you are both right.

My expectation is that KDE should somehow be removable for example unchecking the KDE "group" (really just an icon with KDE beside it) in Add/Remove Software (gpk) should do it.

That it doesn't only remove KDE stuff is not a yum bug because the comps overlap, that it doesn't remove everything that can be reasonably considered part of KDE is not a comps bug because the libs are not components.. It's not realistic to expect PackageKit to code in magic handling of this case.. Itś true but it is a bug SOMEWHERE but I am at loss as to where it belongs then..

Probably not that important
Comment 6 John Poelstra 2008-10-22 17:08:52 EDT
Should this bug remain open?
Comment 7 Kevin Kofler 2008-10-22 17:17:22 EDT
IMHO, this is NOTABUG.

We could certainly list kdelibs3 and kdelibs-common in the group, but they're dragged in by dependencies. And there's KDE 3 stuff in other groups, e.g. kdegames3 as optional in the games group. I don't think yum groupremove is worth trying hard to support, it rarely does what the user expects anyway (think packages in more than one group).
Comment 8 Bug Zapper 2008-11-25 22:54:36 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.