Bug 467148 - X locks up when gdm starts, doesn't seem to hang system
X locks up when gdm starts, doesn't seem to hang system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 19:37 EDT by Trever Adams
Modified: 2008-10-27 19:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 19:12:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested dmesg (25.33 KB, text/plain)
2008-10-20 20:15 EDT, Trever Adams
no flags Details
X startup log (32.56 KB, text/plain)
2008-10-20 20:16 EDT, Trever Adams
no flags Details

  None (edit)
Description Trever Adams 2008-10-15 19:37:56 EDT
Description of problem:
I have a laptop with a 9600 Radeon Mobile. Since moving it to rawhide, it locks up whenever GDM (or X) starts. I have looked at the logs, it doesn't appear the system died, just X. No logs in /var/log/X* or /var/log/messages from X.

Version-Release number of selected component (if applicable):
Latest version (not at the machine)

How reproducible:
Every time.

Steps to Reproduce:
1. Install rawhide on 9600 based machine
2. Start X
  
Actual results:
Crash

Expected results:
Functioning system.

Any tools or help in getting useful debug would be appreciated.
Comment 1 Matěj Cepl 2008-10-17 06:03:42 EDT
You mean you have /var/log/Xorg.*.log? It's hard to believe. Could we then get at least complete /var/log/messages and /var/log/dmesg as separate uncompressed attachments to this bug report, please?

Thank you
Comment 2 Trever Adams 2008-10-17 15:43:33 EDT
I will try to get these off the system today. Yes, I believe there are those logs, I guess they could be old ones. GDM starts, but before the full login screen is completely drawn, X has died.
Comment 3 Trever Adams 2008-10-20 20:13:05 EDT
Ok, if I wait until the mouse cursor appears and then alt-f2 I get gdm up fully, but login locks X.

I have Xorg, dmesg, and messages. I will attach them now.
Comment 4 Trever Adams 2008-10-20 20:14:28 EDT
Sorry, somehow I missed messages. I will get it shortly. However, dmesg also doesn't show a message that the command dmesg did about an mtrr not being alined.
Comment 5 Trever Adams 2008-10-20 20:15:44 EDT
Created attachment 320946 [details]
requested dmesg
Comment 6 Trever Adams 2008-10-20 20:16:05 EDT
Created attachment 320947 [details]
X startup log
Comment 7 Dave Airlie 2008-10-20 20:29:10 EDT
can you try the latest rawhide kernel when it appears...
kernel-2.6.27.3-30.rc1.fc10

it contains some fixes for r300 hw.
Comment 8 Trever Adams 2008-10-21 18:05:38 EDT
I am seeing one crash that I cannot duplicate. It was upon closing Firefox, all of X (and seemingly the system) crashed. It seems unrelated.

Thank you for your fantastic work. I believe you can mark this closed.
Comment 9 Matěj Cepl 2008-10-27 19:12:41 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.