Bug 467150 - SpaceWalk rely on Proprietary Database, should be based on OpenSource Databases
SpaceWalk rely on Proprietary Database, should be based on OpenSource Databases
Status: CLOSED NOTABUG
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Red Hat Satellite QA List
:
Depends On:
Blocks: space04
  Show dependency treegraph
 
Reported: 2008-10-15 20:07 EDT by Ivan Quirino
Modified: 2009-01-16 20:28 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 20:27:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Quirino 2008-10-15 20:07:39 EDT
Description of problem:
Why rely on Oracle 10g Express? Why rely on proprietary database software? To download Oracle 10g Express you need to fill a enormous form, to download a proprietary software. This doesn't make sense, since there's MySQL and PostgreSQL, which are not limited to one database. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jesus M. Rodriguez 2009-01-16 20:27:54 EST
The FAQ on the wiki answers this question:
https://fedorahosted.org/spacewalk/wiki/SpacewalkFaq#WhydoyouuseOracleAnyplansforsupportingotherdatabases

We also have an initiative to port it to using PostgreSQL:
https://fedorahosted.org/spacewalk/wiki/PostgreSqlProject

We all agree that being locked into Oracle is not ideal. But because of
where Spacewalk (and it's downstream Satellite) historically came from
Oracle is what we have for the short term.

Feel free to reopen the bug if you have any further questions, or drop
by #spacewalk on freenode or email us at spacewalk-list@redhat.com

Note You need to log in before you can comment on or make changes to this bug.