Bug 467203 - Anaconda crash on selection of boot loader options
Anaconda crash on selection of boot loader options
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 481073 (view as bug list)
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-10-16 06:57 EDT by Michael Cutler
Modified: 2009-04-15 00:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 00:39:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anacdump.txt (99.69 KB, text/plain)
2008-10-16 06:59 EDT, Michael Cutler
no flags Details
Traceback file from Anaconda (95.52 KB, text/plain)
2008-10-18 06:56 EDT, Tore Anderson
no flags Details
Dump from Anaconda crash on boot loader select (34.08 KB, text/plain)
2008-11-11 08:30 EST, bbradley1946@gmail.com
no flags Details

  None (edit)
Description Michael Cutler 2008-10-16 06:57:28 EDT
Description of problem:

  Anaconda crashed during an upgrade from Fedora Core 9 to Fedora 10-Beta by DVD media. I manually initiated text-mode install because X doesn't start on this machine (I see there are other bugs/workarounds for this though). 'Reinstall System' or, 'Fedora Core 9' (upgrade) appeared as options. I chose to upgrade. At the boot loader selection dialog there are three options, the first (Edit Existing) was grayed out leaving the other two options (Create New, Skip). Selecting Skip allowed me to continue with the installation, I manually had to frig the grub config and ran into other problems. Selecting 'Create New' caused the attached bug report/exception in Anaconda.

The system I was upgrading was a HP DL380G5 which has known problems #466181 'fails to see drives attached to the CCISS adapter', but at the same time I don't expect anaconda to crash because of it.

Trying a fresh install gave me the same problem as #466181 (no drives detected)


Version-Release number of selected component (if applicable):

  Rawhide (Fedora-10-Beta-i386-DVD.iso 25-Sep-2008 18:01  3.4Gb)


How reproducible:

  Every time.


Steps to Reproduce:
  1. Upgrade a HP DL380G5 from FC9 to FC10beta
  2. Select 'Create new' from the boot loader options
  

Actual results:

  Anaconda crashed.


Expected results:

  Exception to be handled gracefully.


Additional info:

  As I said, the HP DL380G5 has various other issues on FC10beta,
    - X-based installer doesnt start, you manually have initiate text mode as there is no option on the boot menu.
    - Drives attached to the CCISS adapter dont appear.
  Yet Anaconda could handle this exception gracefully (its a 'list index out of range' exception).
Comment 1 Michael Cutler 2008-10-16 06:59:09 EDT
Created attachment 320542 [details]
anacdump.txt

anacdump.txt
Comment 2 Tore Anderson 2008-10-18 06:55:20 EDT
Hi,

I'm an old Debian devel and more recently Ubuntu user that's trying Fedora for the first time, have mercy on me if I don't follow bug reporting best practises here...

Anyway, I just tried to install F10 beta (x86_64) on a single-HD PC, which ended in an unhandled exception after clicking next on the page where I set up the boot loader.  I used manual partitioning, left partitions 1 (Windows), 2 (Ubuntu /boot), 3 (Ubuntu LVM) intact, and setup Fedora to have /boot (ext3) on partition 5 and / (ext4) on partition 6.  In the boot loader screen I told it to install Grub in /dev/sda5, and removed the "Other" entry (for Windows).  Upon clicking next I got an error message telling me about an unhandled exception.  I could not save the traceback directly to Bugzilla because AltGr+2, which on my Norwegian keyboard should produce «@» instead incorrectly produced «"» (same as Shift+2), leaving me unable to enter my Bugzilla username.  I'll attach the traceback file here instead if I can figure out how...

Regards,
Tore
Comment 3 Tore Anderson 2008-10-18 06:56:43 EDT
Created attachment 320742 [details]
Traceback file from Anaconda
Comment 4 Tore Anderson 2008-10-18 12:24:23 EDT
I think my bug was caused by a faulty installation medium.  Please ignore it, apologies for the noise.

Tore
Comment 5 Chris Lumens 2008-11-04 10:48:38 EST
Does this work better with the preview release?
Comment 6 bbradley1946@gmail.com 2008-11-11 08:30:07 EST
Created attachment 323171 [details]
Dump from Anaconda crash on boot loader select
Comment 7 bbradley1946@gmail.com 2008-11-11 08:37:26 EST
    I don't know about Tore, but I had the same problem with the preview release. I have an Acer Aspire T135 with two internal SATA hard drives and was attempting a manual install in free space on the second drive (My system is multi-boot with an existing master grub boot partition on the primary drive). On the boot loader window, I pressed the Change button on the first option to switch the location to the local partition (/dev/sdb8) but when I pressed the button to confirm this, anaconda crashed on an exception error. I have attached the dump.
    I tried the install with both the install DVD and the live CD with the same results.
Comment 8 Bug Zapper 2008-11-25 22:55:03 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Chris Lumens 2009-01-22 09:58:23 EST
*** Bug 481073 has been marked as a duplicate of this bug. ***
Comment 10 bbradley1946@gmail.com 2009-03-13 13:38:39 EDT
Just for the record, I tried to install grub to the boot partition in the current alpha version of Fedora 11, and Anaconda STILL crashes on the same exception error. I live in hope that this bug is fixed before the final release.
Comment 11 David Cantrell 2009-04-15 00:39:34 EDT
Not seeing this problem with rawhide as of 14-Apr-2009.  Set up a test system as described in comment #8 using two SATA disks and chose 'Change device' on the bootloader configuration screen.  No traceback.  I was able to change back and forth between sda and sdb1.

Note You need to log in before you can comment on or make changes to this bug.