Bug 467214 - strace -f fails to trace child process in recent kernel
strace -f fails to trace child process in recent kernel
Status: CLOSED DUPLICATE of bug 461552
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 08:36 EDT by Peter Fales
Modified: 2008-10-22 01:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 01:01:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Fales 2008-10-16 08:36:06 EDT
Description of problem:

Starting with kernel 2.6.26, "strace -f" fails to trace child processes. 

Version-Release number of selected component (if applicable):

It worked in kernel-2.6.25.14-69.fc8, and has been failing since kernel-2.6.26.3-14.fc8

How reproducible:

Very


Steps to Reproduce:

Use a simple test program, like bug.c:

  #include <stdio.h>
  main()
  {
        if ( fork() ) {
                printf("parent\n");
        } else {
                printf("child\n");
        }
  }


Then run
 
  strace -f -o strace.out ./bug


Actual results:

An error message is printed, and the child process write() does not appear
in the strace log.   Strangely, I've seen different error messages on different Fedora 8 systems, either:

  PANIC: attached pid 26968 exited
or
  resume: ptrace(PTRACE_SYSCALL, ...): No such process
  

Expected results:

  No error message is printed, and the write("child") appears in the 
  strace.out file


Additional info:

Even though the error comes from strace, I'm assuming that it's actually a problem with the kernel, because reverting to an earlier kernel version causes the problem to go away.

I'm seeing the problem in both Fedora 8 and Fedora 9, and in both cases it starts showing up in the 2.6.26.* kernels
Comment 1 Chuck Ebbert 2008-10-22 01:01:49 EDT

*** This bug has been marked as a duplicate of bug 461552 ***

Note You need to log in before you can comment on or make changes to this bug.