Bug 46725 - Space doesn't click buttons on TUI Bootloader Configuration screen
Space doesn't click buttons on TUI Bootloader Configuration screen
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-29 20:59 EDT by Brent Nordquist
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-02 11:33:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent Nordquist 2001-06-29 20:59:37 EDT
Description of Problem:
When doing a TUI install, on the screen labeled Bootloader Configuration,
the spacebar doesn't make the Ok, Edit, etc. buttons click as it does on
other screens.

Workaround:
Press return instead.

How Reproducible:
Always.

Steps to Reproduce:
1. Begin a text-mode install.
2. Arrive at Bootloader Configuration screen.
3. Tab to highlight Ok button, and press space.

Actual Results:
Nothing happens.

Expected Results:
The Ok button would be depressed.

Additional Information:
Comment 1 Brent Fox 2001-06-30 10:57:42 EDT
I can't reproduce this behavior.  The initial focus is in the text entry widget,
so that might be the problem you are seeing.  I think that if you hit the <Tab>
button until one of the buttons is highlighted, then the space bar should work.
It does for me, anyway.
Comment 2 Brent Nordquist 2001-06-30 11:51:52 EDT
Is there an appeals process?  :-)  Seriously, I do understand about tab and
focus, I use it all the time.  See step #3 above.  It was quite consistent the
whole night I was installing; the Ok button was highlighted but space didn't
click it (although return did), just on that one screen.

Just to clarify (not to question your methods):  Were you testing with Fairfax
beta1, or with rawhide?  Are you 100% sure you were on the same screen I was?
I'm just puzzled why it would happen for me and not for you... there must be
some difference in what we did.

Thanks!
Comment 3 Brent Nordquist 2001-07-02 10:23:02 EDT
I'm reopening this because (a) you say "the initial focus is in the text entry
widget" but the screen I'm talking about doesn't have a text entry widget, and
(b) it was happening to me all weekend on a different machine.  I'm pretty sure
we're not looking at the same screen.

I'm talking about the TUI dialog labeled [Bootloader Configuration] that has, in
the top half, a scrolling list of partitions to boot from, and in the bottom
half, three buttons labeled "Ok" "Edit" and "Back".  (Clicking "Edit" allows you
to change the name of the highlighted boot partition, for example.)  After
tabbing to any of these buttons (the button text is highlighted), "space" fails
to click it.

I noticed that pressing space while the top half scrolling list has focus will
cause the highlighted list item to become the "Default" boot partition... I'm
wondering if that behavior is somehow inhibiting the buttons from being clicked
when space is pressed when they're highlighted.
Comment 4 Brent Fox 2001-07-02 11:16:37 EDT
Oh, I was looking at the first screen entitled "Bootloader Configuration" which
has the text:
"A few systems will need to pass special options ot the kernel at boot time for
the system to function properly.  If you need to pass boot options to the
kernel, enter them now.  If you don't need any or aren't sure, leave this blank."

We were looking at different screens.  I'm taking another look at this now.
Comment 5 Brent Fox 2001-07-02 11:33:44 EDT
You are right.  Actually, there are three different screens with "Bootloader
Configuration" at the top in text mode.  The last one demonstrates the behavior
you are seeing.  
I just committed a fix to cvs.  For some reason, there was a line:
g.addHotKey(" ")
that, as far as I can tell, didn't do anything except prevent the space bar from
working properly.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.