Bug 467255 - Spinfinity falls back to terminal with timeout assertion
Spinfinity falls back to terminal with timeout assertion
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 11:29 EDT by Jaroslav Reznik
Modified: 2008-10-31 08:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 17:56:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2008-10-16 11:29:41 EDT
Description of problem:
Spinfinity falls back to terminal with timeout assertion.

Version-Release number of selected component (if applicable):
Rawhide

How reproducible:
Boot Fedora Rawhide with Plymouth enabled.

Steps to Reproduce:
1. Enable Plymouth
2. Boot Fedora
  
Actual results:
Plymouth falls back to terminal with error message:

plymouthd: ply-event-loop.c:875: ply_event_loop_watch_for_timeout: Assertion 'seconds > 0.0' failed.


Expected results:
Plymouth boots without falling back to text mode.

Additional info:
Spinfinity plugin.
Comment 1 Ray Strode [halfline] 2008-10-16 14:56:40 EDT
what version of plymouth?
Comment 2 Jaroslav Reznik 2008-10-17 04:35:46 EDT
plymouth-0.6.0-0.2008.10.15.1.fc10.i386
Comment 3 Ray Strode [halfline] 2008-10-23 10:41:55 EDT
I can't find any place in the code where watch_for_timeout would have seconds <= 0.0.

Maybe you have a stale version of plymouth in your initrd?

if you run 

/sbin/mkinitrd -f /boot/initrd-$(uname -r).img $(uname -r)

does the problem go away?
Comment 4 Ray Strode [halfline] 2008-10-30 17:56:37 EDT
Hi,

I'm going to go ahead and close this out because I think you may have had a stale version of plymouth in your initrd.

If you see this again, please reopen.
Comment 5 Jaroslav Reznik 2008-10-31 08:23:22 EDT
Hi,
ok. Sorry for not responding but I'm not able to boot to this testing virtual machine - problems with VBox. If I see it again, I'll repopen it. Thanks.

Note You need to log in before you can comment on or make changes to this bug.