Bug 467256 - Publican XSL stylesheet for PDF missing namespace declaration
Publican XSL stylesheet for PDF missing namespace declaration
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 11:32 EDT by Paul W. Frields
Modified: 2010-11-23 23:16 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.39
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 00:31:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to pdf.xsl to include rx namespace (459 bytes, patch)
2008-10-16 11:38 EDT, Paul W. Frields
no flags Details | Diff

  None (edit)
Description Paul W. Frields 2008-10-16 11:32:58 EDT
The namespace declarations at top should include:

xmlns:rx="http://www.renderx.com/XSL/Extensions"
Comment 1 Paul W. Frields 2008-10-16 11:38:54 EDT
Created attachment 320566 [details]
Patch to pdf.xsl to include rx namespace
Comment 2 Jeff Fearn 2008-10-16 20:05:52 EDT
What error is occurring that requires this to be added?
Comment 3 Paul W. Frields 2008-10-17 07:01:42 EDT
I'm trying to use the pdf.xsl stylesheet as an antecedent for a custom stylesheet of my own.  The error message that appears during processing is:

compilation error: file /usr/share/publican/xsl/pdf.xsl line 1597 element attribute
xsl:attribute: The prefixed QName 'rx:key' has no namespace binding in scope in the stylesheet; this is an error, since the namespace was not specified by the instruction itself.

q.v. http://www.w3.org/TR/xml-names11/
Comment 4 Jeff Fearn 2008-10-19 17:41:12 EDT
Oh! I wonder how that xep hook got through? I usually remove all the closed source stuff when I customise as I can't test it; including it may give someone the wrong idea about us being able to support commercial software.

Still, using this file as an antecedent is exactly how the fedora brand package overrides it, so I guess you must be using xep since this code only gets hit if xep.extensions is not 0.

I shall poll the list.
Comment 5 Jeff Fearn 2008-10-23 00:31:16 EDT
Added name space, no one seemed fussed.
Comment 6 Fedora Update System 2008-12-01 00:39:34 EST
publican-0.39-0.fc9,publican-fedora-0.16-0.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/publican-0.39-0.fc9,publican-fedora-0.16-0.fc9
Comment 7 Fedora Update System 2009-01-14 21:56:13 EST
publican-0.39-0.fc9, publican-fedora-0.16-0.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.