Bug 467278 - Two finger tap lost in synaptics 0.15.1-2
Two finger tap lost in synaptics 0.15.1-2
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 12:58 EDT by Juta Sirakas
Modified: 2008-10-24 19:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 19:52:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The xorg.log (29.16 KB, text/plain)
2008-10-17 10:58 EDT, Gustavo Maciel Dias Vieira
no flags Details

  None (edit)
Description Juta Sirakas 2008-10-16 12:58:44 EDT
Description of problem:
right-click (two finger tap) lost in latest synaptics driver (xorg-x11-drv-synaptics-0.15.1-2.fc9.x86_64)
After update from 0.15.0 to 0.15.1-2 it did not work any more.

xorg.conf:
Section "InputDevice"
	Identifier  "Synaptics Touchpad"
	Driver      "synaptics"
	Option	    "CorePointer"
	Option	    "Device" "/dev/input/mouse1"
	Option	    "Protocol" "auto-dev"
	Option	    "LeftEdge" "10"
	Option	    "RightEdge" "1206"
	Option	    "TopEdge" "8"
	Option	    "BottomEdge" "380"
	Option	    "FingerLow" "20"
	Option	    "FingerHigh" "30"
	Option	    "MaxTapTime" "100"
	Option	    "MaxTapMove" "0"
	Option	    "MaxDoubleTapTime" "100"
	Option	    "VertScrollDelta" "30"
	Option	    "HorizScrollDelta" "96"
	Option	    "MinSpeed" "0.79"
	Option	    "MaxSpeed" "0.88"
	Option	    "AccelFactor" "0.0015"
	Option	    "SHMConfig" "on"
	Option	    "VertTwoFingerScroll" "true"
	Option	    "HorizTwoFingerScroll" "true"
	Option	    "TapButton2" "3"
	Option	    "TapButton3" "2"
EndSection

X log attached
Comment 1 Peter Hutterer 2008-10-17 02:19:24 EDT
>  Option     "MaxTapMove" "0"

Can you increase MaxTapMove, maybe to 60 or so? 
Also, please attach the xorg.log.

You don't need the Device option if you have Protocol as auto-dev, and you don't need auto-dev since it is the default anyway. Likewise CorePointer is redundant.

Please also attach the output of synclient -m 20 when doing a two-finger tap.
Comment 2 Gustavo Maciel Dias Vieira 2008-10-17 10:58:52 EDT
Created attachment 320673 [details]
The xorg.log
Comment 3 Gustavo Maciel Dias Vieira 2008-10-17 10:59:28 EDT
I have the same problem here. It was working with 0.15.0-3 and broke with 0.15.1-2.

Actually, the tap still works, but I have to tap many times before one of the clicks is recognized. Timing problems maybe?

My xorg.conf file doesn't have a InputDevice for the touchpad.

The output of synclient -m 20 is:

[gdvieira@puck ~]$ synclient -m 20
Can't access shared memory area. SHMConfig disabled?

My xorg.log is attached.
Comment 4 Jason Turning 2008-10-19 16:38:33 EDT
My tap functionality became incredibly buggy once upgraded to 1.15.2-1. I tried all xorg.conf changes, gsynaptics settings, and my tap functionality was still damaged. I actually thought it might be a hardware problem and booted into Vista to check, and it worked perfectly under Vista. I then reverted to 1.15.0.3 and tap functionality was restored. It would appear 1.15.2-1 broke something.
Comment 5 Fedora Update System 2008-10-20 01:10:32 EDT
xorg-x11-drv-synaptics-0.15.1-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-0.15.1-3.fc9
Comment 6 Adrian "Adi1981" P. 2008-10-22 11:03:49 EDT
xorg-x11-drv-synaptics-0.15.1-3.fc9 fixed tapping issue for me.
Comment 7 Fedora Update System 2008-10-23 12:42:09 EDT
xorg-x11-drv-synaptics-0.15.1-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-synaptics'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9112
Comment 8 Kyle Pablo 2008-10-24 12:14:55 EDT
Tried the update and fixed it.
Comment 9 Fedora Update System 2008-10-24 19:52:38 EDT
xorg-x11-drv-synaptics-0.15.1-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.