Bug 467283 - dmraid failures at install time
dmraid failures at install time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-16 13:17 EDT by Jesse Keating
Modified: 2013-01-09 22:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 16:24:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (6.85 KB, text/plain)
2008-10-16 13:17 EDT, Jesse Keating
no flags Details
syslog from the install (41.44 KB, text/plain)
2008-10-16 13:19 EDT, Jesse Keating
no flags Details
anaconda.log with the issue (3.14 KB, text/plain)
2008-10-19 15:30 EDT, Panagiotis Kalogiratos
no flags Details
Output of dmraid -tay -dddd -vvvv -f nvidia (3.69 KB, text/plain)
2008-10-19 15:43 EDT, Panagiotis Kalogiratos
no flags Details

  None (edit)
Description Jesse Keating 2008-10-16 13:17:57 EDT
Created attachment 320581 [details]
anaconda log

I've got a system with dmraid in it, and an existing install.  The subsystem is able to detect the dmraid and create the /dev/dm-0 devices seemingly correct, but anaconda seems to fail to mount it correctly, and treats the devices individually.  I'll attached the logs.
Comment 1 Jesse Keating 2008-10-16 13:19:39 EDT
Created attachment 320582 [details]
syslog from the install

above the dhcp spew you'll see the dmraid failure messages in syslog.
Comment 2 Panagiotis Kalogiratos 2008-10-19 14:30:19 EDT
I'm noticing similar failures on installation of F8,F9 and F10. The board used is an ASUS P5N32-E SLI with nforce i680 chipset. The fakeraid array is 4 drive 0+1 (There is a NTFS partition present created by vista--starting at 1mb).

 Anaconda logs show dmraid loading but doing absolutely nothing. There is no mention of the /dev/mapper/nvidia_etc device at all and anaconda displays only the physical drives. Upon inspection of /dev/mapper the devices are missing.

 Using F9 and F10 live cds I am able to dmraid -ay which creates the device mapper links but running liveinst or anaconda manually exhibits almost the same behaviour. The difference is the drive components of the array do not appear at the partitioning part of the installation, they are skipped, but no device mapper device appears as well...

I tried a live cd of Ubuntu Intrepid Ibex and the device appeared in their installer after I install dmraid.

Is there a minimum free space value that anaconda checks?
Comment 3 Panagiotis Kalogiratos 2008-10-19 15:30:20 EDT
Created attachment 320814 [details]
anaconda.log with the issue
Comment 4 Panagiotis Kalogiratos 2008-10-19 15:43:17 EDT
Created attachment 320815 [details]
Output of dmraid -tay -dddd -vvvv -f nvidia

I can mount the ntfs partition on it manually
Comment 5 Joel Andres Granados 2008-10-20 05:48:55 EDT
In the installer,  I change to tty2 and run `dmraid -s -c` to find that it is unable to recognize my isw raid set.  Could this be a dmraid library issue?
Comment 6 Joel Andres Granados 2008-10-20 07:42:45 EDT
After installing rawhide from oct 19 and running `dmraid -s -c` I noticed the same errors.  Additionally, I also ran `dmraid -tay -dddd -vvvv -f isw` both on the installation and on the installed system; with the same results.
Comment 7 Panagiotis Kalogiratos 2008-10-20 10:20:40 EDT
I'm not familiar with the code in anaconda but from looking at the logs it seems to me that anaconda calls dmraid and probably doesn't bother to check /dev/mapper for devices unless they're created in the process?
 Since running dmraid -ay can link the devices to /dev/mapper, I'm led to believe that anaconda is doing something wrong/unorthodox in the dmraid detection process. My test with the Ubuntu installer verified (at least in my case) that I have no corrupted nvraid metadata or issue with the raid set.
Comment 8 Joel Andres Granados 2008-10-20 12:07:02 EDT
Anaconda first scans for dmraid devices, using the dmraid library, the creates the devmapper nodes and then continues.  Now if dmraid -s -c fails in the installer and in the installed system, It suggests to me that it is a dmraid library problem.  if dmraid correctly lists the dmraid sets on the system and anaconda still fails it could be in the python-pyblock package, or in anaconda itself.
Comment 9 Panagiotis Kalogiratos 2008-10-20 13:58:59 EDT
dmraid -s -c doesn't fail in my case, at least not when run outside the installer. It's only anaconda that fails to detect it. If you check my log:
-----------------
22:23:35 DEBUG   : starting dmraids
22:23:35 DEBUG   : self.driveList(): ['sda', 'sdb', 'sdc', 'sdd', 'sde', 'sdf']
22:23:35 DEBUG   : DiskSet.skippedDisks: []
22:23:35 DEBUG   : DiskSet.skippedDisks: []
22:23:35 DEBUG   : starting all dmraids on drives ['sda', 'sdb', 'sdc', 'sdd', 'sde', 'sdf']
22:23:35 DEBUG   : scanning for dmraid on drives ['sda', 'sdb', 'sdc', 'sdd', 'sde', 'sdf']
22:23:35 DEBUG   : done starting dmraids.  Drivelist: ['sda', 'sdb', 'sdc', 'sdd', 'sde', 'sdf']
-----------------

in comparison to the log attached by Jesse Keating:
-----------------
17:08:31 DEBUG   : starting dmraids
17:08:31 DEBUG   : self.driveList(): ['sda', 'sdb']
17:08:31 DEBUG   : DiskSet.skippedDisks: []
17:08:31 DEBUG   : DiskSet.skippedDisks: []
17:08:31 DEBUG   : starting all dmraids on drives ['sda', 'sdb']
17:08:31 DEBUG   : scanning for dmraid on drives ['sda', 'sdb']
17:08:31 DEBUG   : got raidset <block.device.RaidSet instance at 0x7fcaf60e20e0> (sdb sda)
17:08:31 DEBUG   :   valid: True found_devs: 2 total_devs: 2
17:08:31 DEBUG   : adding mapper/nvidia_gddebeda to isys cache
17:08:31 DEBUG   : adding sdb to dm cache
17:08:31 DEBUG   : removing sdb from isys cache
17:08:31 DEBUG   : adding sda to dm cache
17:08:31 DEBUG   : removing sda from isys cache
17:08:31 DEBUG   : starting raid <block.device.RaidSet instance at 0x7fcaf60e20e0> with mknod=True
17:08:31 ERROR   : Activating raid nvidia_gddebeda failed: 
17:08:31 ERROR   : Activating raid nvidia_gddebeda failed: 
17:08:31 ERROR   :   table: 0 144603392 striped 2 128 /dev/sdb 0 /dev/sda 0
17:08:31 ERROR   :   table: 0 144603392 striped 2 128 /dev/sdb 0 /dev/sda 0
17:08:31 ERROR   :   exception: /dev/mapper/nvidia_gddebeda: matchpathcon 0060000 failed: Invalid argument
17:08:31 ERROR   :   exception: /dev/mapper/nvidia_gddebeda: matchpathcon 0060000 failed: Invalid argument
17:08:31 DEBUG   : done starting dmraids.  Drivelist: ['mapper/nvidia_gddebeda']
17:08:31 DEBUG   : adding drive mapper/nvidia_gddebeda to disk list
----------------

it looks like anaconda does nothing at all in my case.

 Is there any way to force anaconda to read /dev/mapper when I create the nodes outside the installer? It would be handy as a workaround in my case.
Comment 10 Jesse Keating 2008-10-20 16:24:45 EDT
I can no longer reproduce as of 10/20.  This doesn't seem to be a bug anymore, at least not the way I was seeing it.  If other people are having different issues with dmraid I suggest they open bugs specific to their issues.

Note You need to log in before you can comment on or make changes to this bug.