Bug 467285 - evince doesn't select highlight properly
evince doesn't select highlight properly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: poppler (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Marek Kašík
Desktop QE
: ZStream
: 521234 (view as bug list)
Depends On:
Blocks: 703175
  Show dependency treegraph
 
Reported: 2008-10-16 13:28 EDT by Alan Matsuoka
Modified: 2012-02-21 01:11 EST (History)
5 users (show)

See Also:
Fixed In Version: poppler-0.5.4-16.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 01:11:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
csn738.pdf (184.76 KB, application/pdf)
2008-10-16 13:28 EDT, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2008-10-16 13:28:33 EDT
Created attachment 320584 [details]
csn738.pdf

Description of problem:
If you have a multi-column PDF file and you try to select text in one column it picks up text in other columns

How reproducible:
always

Steps to Reproduce:
Open up a multi-column PDF file in evince and try to select some text.

Actual results:
Notice how it splits grabs text in other columns.

Expected results:
It selects text just in that column unless you move across to a new column.

Additional info:
Acrobat does this properly.

Not likely to be fixed upstream anytime soon by the looks of it.

http://bugzilla.gnome.org/show_bug.cgi?id=325189
https://bugs.freedesktop.org/show_bug.cgi?id=4006
https://bugs.freedesktop.org/show_bug.cgi?id=3188

It's been around for a long time and it's said to be difficult to fix.
Comment 1 Issue Tracker 2008-10-16 13:29:51 EDT
I'm beginning to think that
https://bugs.freedesktop.org/show_bug.cgi?id=3188#c3 is right.


This event sent from IssueTracker by alanm 
 issue 176665
Comment 2 RHEL Product and Program Management 2009-03-26 13:19:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 12 Marek Kašík 2009-11-20 09:25:22 EST
*** Bug 521234 has been marked as a duplicate of this bug. ***
Comment 18 RHEL Product and Program Management 2010-08-09 15:51:29 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 29 errata-xmlrpc 2012-02-21 01:11:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0236.html

Note You need to log in before you can comment on or make changes to this bug.