Bug 467294 - mono-cairo.pc broken
mono-cairo.pc broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 460663
  Show dependency treegraph
 
Reported: 2008-10-16 14:13 EDT by Dan Winship
Modified: 2009-03-07 17:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 19:14:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Winship 2008-10-16 14:13:42 EDT
> pkg-config --libs mono-cairo
-r:/usr/lib64/pkgconfig/../../lib/mono/1.0/Mono.Cairo.dll  

which doesn't work, because it's in lib64, not lib.

patching it to just say "-r:Mono.Cairo.dll" instead of "-r:${prefix}/lib/mono/1.0/Mono.Cairo.dll" appears to work fine, though I haven't tested extensively...
Comment 1 Paul F. Johnson 2008-10-16 19:14:42 EDT
Thanks for the report - fixed in the next push

Note You need to log in before you can comment on or make changes to this bug.