Bug 467318 - Thinkpad X200/cantiga/gm45: crash on resume
Thinkpad X200/cantiga/gm45: crash on resume
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 16:19 EDT by Jeremy Fitzhardinge
Modified: 2008-11-17 17:50 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 17:50:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of X server starting normally. (81.68 KB, text/plain)
2008-10-16 16:19 EDT, Jeremy Fitzhardinge
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 18049 None None None Never

  None (edit)
Description Jeremy Fitzhardinge 2008-10-16 16:19:42 EDT
Created attachment 320604 [details]
Log of X server starting normally.

Description of problem:
When using the Intel X driver, the system crashes on resume.  The display reappears, but then the system just hangs.

Version-Release number of selected component (if applicable):
kernel-2.6.27-13.fc10.x86_64
xorg-x11-drv-i810-2.4.2-12.fc10.x86_64
libdrm-2.4.0-0.21.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start X
2. Suspend machine
3. Resume
  
Actual results:
Display appears, but machine locks up

Expected results:
Proper resume to usable system.

Additional info:
This is the first kernel version in which using the intel driver works at all, so good work there.

I tried getting some output with netconsole, but apparently the e1000e driver wasn't up at that point.

I haven't tried i915.modeset=1
Comment 1 Jeremy Fitzhardinge 2008-10-16 19:27:48 EDT
Crashes on resume from hibernate as well.

i915.modeset=1 seems pretty broken, which I guess is expected.
Comment 2 Jeremy Fitzhardinge 2008-10-16 22:31:51 EDT
If I switch to a text vt before suspending, and then resume, the machine works fine.  When I switch to X, it works normally for several seconds (animated icons, pointer moves, etc) before the machine locks up.

I'll try to see if anything appears on netconsole next time.
Comment 3 Jeremy Fitzhardinge 2008-10-21 17:07:42 EDT
Further observations:

 - nothing appears on netconsole when it crashes
 - switching to a text vt and using pm-suspend will resume properly; when switching to the X vt, there's a fairly good chance it will resume properly without hanging (maybe ~60% of the time it works)
Comment 4 Ugo Viti 2008-10-30 16:03:37 EDT
Hi,

can you try in order:

open a console, become root (su -) and write:

pm-suspend --quirk-s3-bios --quirk-s3-mode

else

pm-suspend --quirk-vbemode-restore

else

pm-suspend --quirk-vbestate-restore

else

pm-suspend --quirk-vbe-post

else

pm-suspend --quirk-dpms-on

let me know.

Best Regards.
Comment 5 Jeremy Fitzhardinge 2008-11-03 19:58:56 EST
OK, I tried all those.  The first one just hangs immediately on resume, leaving the screen blank and no activity other than the fan blowing.

The rest have the same symptom as nothing at all: X resumes, I see what was on the screen at suspend time, but the machine is completely locked up.
Comment 6 Ugo Viti 2008-11-04 15:50:28 EST
Hi,

try the following site:

http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-debug.html
Comment 7 Jeremy Fitzhardinge 2008-11-06 16:05:59 EST
I looked over that, but I don't see anything I haven't already tried.  I think this is pretty clearly a kernel bug at some level, but I don't have any idea how to make more progress on this.

It is, however, a pretty serious blocker for me, as it breaks suspend/resume on my laptop (the only workaround is that hibernate works reliably, albeit painfully slowly).
Comment 8 Need Real Name 2008-11-06 16:51:38 EST
I saw mention of the same problem on an Ubuntu thread and someone suggested a script in /etc/pm/sleep.d/ that disabled extra CPUs during suspend/resume.

I tried this on my X200 with Intel driver, and set the script to sleep for 60 seconds on resume before reenabling the extra core. I was able to use the X desktop for that 60 seconds, and then it froze up. :-)

Anyway, a workaround for your laptop is to use the "vesa" driver instead of "intel" if you need suspend to work in the short term. Of course, you don't get all the acceleration.
Comment 9 Sven Lankes 2008-11-09 08:21:30 EST
Jeremy, 

Do you have compiz/desktopeffects enabled? I'm having the same issue but it goes away when I disable desktop effects (this is also on rawhide x86_64 - on a dell m1330).
Comment 10 Bryan O'Sullivan 2008-11-09 11:32:15 EST
I have the same hardware as Jeremy, and I definitely don't use compositing, but I see the same problem.
Comment 11 Jeremy Fitzhardinge 2008-11-09 13:10:32 EST
(In reply to comment #9)
> Do you have compiz/desktopeffects enabled? I'm having the same issue but it
> goes away when I disable desktop effects (this is also on rawhide x86_64 - on a
> dell m1330).

No, I'm not using anything like that.
Comment 12 Jeremy Fitzhardinge 2008-11-12 01:08:44 EST
According to http://bugs.freedesktop.org/show_bug.cgi?id=18049#c10 this patch will fix the problem:  http://lists.freedesktop.org/archives/intel-gfx/2008-November/000508.html

I have not tried it yet.
Comment 13 Dave Airlie 2008-11-12 01:21:13 EST
it should be included in kernel 2.6.27.5-101 which is building now.
Comment 14 Jeremy Fitzhardinge 2008-11-12 10:24:59 EST
Thanks, 2.6.27.5-101 resumes properly for me now.
Comment 15 Bernie Innocenti 2008-11-14 16:36:58 EST
(In reply to comment #14)
> Thanks, 2.6.27.5-101 resumes properly for me now.

2.6.27-5.101 worked once for me, and hung the second time.  My configuration is an X200s with compiz enabled.

Can you confirm it works reliably for you?
Comment 16 Bernie Innocenti 2008-11-14 16:44:06 EST
Just tried now with 2.6.27.5-101:

 * with no 3D running, I can reliably suspend and resume.

 * If I suspend when glxgears is running, on resume the glxgears window
   remains black until I drag it around.

 * Running compiz makes the system freeze occasionally even without suspend.
Comment 17 Jeremy Fitzhardinge 2008-11-14 18:03:09 EST
It has been reasonably stable when I don't use 3d (I don't habitually use compiz).

Its much less reliable using 3d.  I ran googleearth for a while (much better performance than last time I tried), but after a while the textures started getting corrupted, then the whole screen, then X crashed, then the machine.

Similarly running a 3D windows game under Wine - worked OK, but it destabilized the machine after a while.

So I think this particular bug is fixed, but there are still general stability issues with 3D.
Comment 18 Dave Airlie 2008-11-17 17:50:30 EST
resume fixed closing.

Note You need to log in before you can comment on or make changes to this bug.