Bug 467328 - 500 ise after clicking on snapshot tag profile
500 ise after clicking on snapshot tag profile
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Partha Aji
wes hayutin
https://dhcp231-223.rdu.redhat.com/ne...
:
Depends On:
Blocks: space03
  Show dependency treegraph
 
Reported: 2008-10-16 16:51 EDT by wes hayutin
Modified: 2009-09-17 03:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:02:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2008-10-16 16:51:46 EDT
Description of problem:

recreate.
1. register system, enable provisioning
2. create a snapshot tag, system -> provisioning -> snapshot tags
3. install a package via webui
4. go back to snapshot tag, click on the tag..

get 500 ise

[Thu Oct 16 12:42:21 2008] [error] Execution of /var/www/html/network/systems/details/history/snapshots/rollback.pxt failed at Thu Oct 16 12:42:21 2008: RHN::Exception: Attempt to set invalid mode 'groups_a_system_is_in' for datasource 'RHN::DataSource::SystemGroup'\n  RHN::DataSource /var/www/lib/RHN/DataSource.pm 68 RHN::Exception::throw\n  RHN::DB::SystemSnapshot /var/www/lib/RHN/DB/SystemSnapshot.pm 110 RHN::DataSource::mode\n  Sniglets::Snapshot /var/www/lib/Sniglets/Snapshot.pm 145 RHN::DB::SystemSnapshot::group_diffs\n  PXT::Parser /var/www/lib/PXT/Parser.pm 171 Sniglets::Snapshot::snapshot_details\n  PXT::Parser /var/www/lib/PXT/Parser.pm 83 PXT::Parser::expand_tag\n  PXT::ApacheHandler /var/www/lib/PXT/ApacheHandler.pm 632 PXT::Parser::expand_tags\n  PXT::ApacheHandler /var/www/lib/PXT/ApacheHandler.pm 123 PXT::ApacheHandler::pxt_parse_data\n  PXT::ApacheHandler /var/www/lib/PXT/ApacheHandler.pm 123 (eval)\n  main -e 0 PXT::ApacheHandler::handler\n  main -e 0 (eval)
[Thu Oct 16 12:42:21 2008] [error] Traceback sent to whayutin@redhat.com at /var/www/lib/PXT/ApacheHandler.pm line 729.
[Thu Oct 16 12:42:22 2008] [error] Class list: $VAR1 = 'Grail::Frame';\n$VAR2 = 'Sniglets::Users';
[Thu Oct 16 12:42:22 2008] [error] Class list: $VAR1 = 'Sniglets::Users';\n$VAR2 = 'Sniglets::HTML';\n$VAR3 = 'Grail::Frame';\n$VAR4 = 'Sniglets::Navi';
[Thu Oct 16 12:42:22 2008] [error] Class list: $VAR1 = 'Sniglets::Header';
[Thu Oct 16 12:42:22 2008] [error] Class list: $VAR1 = 'Sniglets::Navi';
[Thu Oct 16 12:42:22 2008] [error] config web.product_name not in master config list in PXT::Config at /var/www/lib/PXT/Config.pm line 163.
[Thu Oct 16 12:42:22 2008] [error] Class list: $VAR1 = 'Sniglets::Users';\n$VAR2 = 'Sniglets::Lists';\n$VAR3 = 'Sniglets::HTML';
[Thu Oct 16 12:42:22 2008] [error] Class list: $VAR1 = 'Sniglets::Users';\n$VAR2 = 'Sniglets::Header';\n$VAR3 = 'Sniglets::Search';\n$VAR4 = 'Sniglets::Sets';
[Thu Oct 16 12:42:22 2008] [error] Class list:  at /var/www/lib/PXT/ApacheHandler.pm line 527.
[Thu Oct 16 12:42:22 2008] [error] Class list: $VAR1 = 'Sniglets::Utils';\n$VAR2 = 'Sniglets::Users';
[Thu Oct 16 12:42:22 2008] [error] Class list:  at /var/www/lib/PXT/ApacheHandler.pm line 527.
[Thu Oct 16 12:44:14 2008] [error] Class list: $VAR1 = 'Grail::Frame';\n$VAR2 = 'Sniglets::Servers';\n$VAR3 = 'Sniglets::Users';\n$VAR4 = 'Sniglets::Navi';\n$VAR5 = 'Sniglets::HTML';\n$VAR6 = 'Sniglets::Lists';
[Thu Oct 16 12:44:14 2008] [error] Class list:  at /var/www/lib/PXT/ApacheHandler.pm line 527.
[Thu Oct 16 12:44:17 2008] [error] Class list: $VAR1 = 'Sniglets::Users';\n$VAR2 = 'Sniglets::HTML';\n$VAR3 = 'Grail::Frame';\n$VAR4 = 'Sniglets::Navi';
[Thu Oct 16 12:44:17 2008] [error] Class list: $VAR1 = 'Sniglets::Header';
[Thu Oct 16 12:44:17 2008] [error] Class list: $VAR1 = 'Sniglets::Navi';
[Thu Oct 16 12:44:17 2008] [error] config web.product_name not in master config list in PXT::Config at /var/www/lib/PXT/Config.pm line 163.
[Thu Oct 16 12:44:17 2008] [error] Class list: $VAR1 = 'Sniglets::Users';\n$VAR2 = 'Sniglets::Lists';\n$VAR3 = 'Sniglets::HTML';
[Thu Oct 16 12:44:17 2008] [error] Class list: $VAR1 = 'Sniglets::Users';\n$VAR2 = 'Sniglets::Header';\n$VAR3 = 'Sniglets::Search';\n$VAR4 = 'Sniglets::Sets';
[Thu Oct 16 12:44:17 2008] [error] Class list:  at /var/www/lib/PXT/ApacheHandler.pm line 527.
[Thu Oct 16 12:44:17 2008] [error] Class list: $VAR1 = 'Sniglets::HTML';\n$VAR2 = 'Sniglets::Servers';\n$VAR3 = 'Sniglets::Users';
[Thu Oct 16 12:44:17 2008] [error] Class list:  at /var/www/lib/PXT/ApacheHandler.pm line 527.
[Thu Oct 16 12:44:17 2008] [error] Class list: $VAR1 = 'Sniglets::Utils';\n$VAR2 = 'Sniglets::Users';
Comment 1 Clifford Perry 2008-10-21 13:31:12 EDT
Partha - looks like this broke due to a commit change made by you to remove code during a perl -> java page port. Seems there was other parts of code calling the 'groups_a_system_is_in' for datasource. 

Need this fixed today please :)

Thanks,
Cliff
Comment 2 Jesus M. Rodriguez 2008-10-30 10:04:29 EDT
I'm seeing this exact same error during channel creation.
Comment 3 Devan Goodwin 2008-11-04 13:49:12 EST
No exception occurring in spacewalk 0.3, and groups_a_system_is_in is appearing in RHN/DB/DataSource/xml/SystemGroup_queries.xml.

Verified.
Comment 4 Miroslav Suchý 2009-09-17 03:02:10 EDT
Spacewalk has been released for some time.

Note You need to log in before you can comment on or make changes to this bug.