Bug 467332 - VT Switching with Compiz running on i965 locks up machine on resume
VT Switching with Compiz running on i965 locks up machine on resume
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 466995 (view as bug list)
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-10-16 17:20 EDT by Ben Gamari
Modified: 2009-10-22 09:00 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 06:36:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full Xorg.0.log after (temporary) lockup (192.91 KB, text/plain)
2008-11-02 21:42 EST, Will Woods
no flags Details
Keith's patch fixing vblank counter tracking (2.96 KB, patch)
2008-11-18 13:34 EST, Ben Gamari
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 18062 None None None Never
FreeDesktop.org 18098 None None None Never

  None (edit)
Description Ben Gamari 2008-10-16 17:20:07 EDT
Description of problem:
VT switching with compiz running on i965 causes the machine to come up with a slightly corrupted black screen, and frozen mouse and keyboard. This is apparently tied to GEM and Intel is looking into this.

See Freedesktop bug 18062.
Comment 1 Tim Lauridsen 2008-10-18 01:54:27 EDT
i have the same issue on my Thinkpad T60 with a builtin intel graphics adaptor.

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

the problem only occurs when compiz is enabled.
Comment 2 Will Woods 2008-11-02 21:25:49 EST
I have similar troubles with an i915; black screen on resume/VT switch, only when compiz is enabled.

*but* - sometimes the machine comes back from being stuck. And there are interesting things in Xorg.0.log afterward:

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x3b) [0x812b94b]
1: /usr/bin/Xorg(mieqEnqueue+0x289) [0x810b069]
2: /usr/bin/Xorg(xf86PostMotionEventP+0xc2) [0x80d3892]
3: /usr/bin/Xorg(xf86PostMotionEvent+0x68) [0x80d39f8]
4: /usr/lib/xorg/modules/input//synaptics_drv.so [0x4ba8fe]
5: /usr/lib/xorg/modules/input//synaptics_drv.so [0x4bcf79]
6: /usr/bin/Xorg [0x80bfaa7]
7: /usr/bin/Xorg [0x80aa22e]
8: [0x110400]
9: [0x110416]
10: /lib/libc.so.6(ioctl+0x19) [0x294939]
11: /usr/lib/libdrm.so.2 [0x47e26cf]
12: /usr/lib/libdrm.so.2(drmWaitVBlank+0x28) [0x47e2e08]
13: /usr/lib/dri/i915_dri.so [0x5c59dc]
14: /usr/lib/dri/i915_dri.so(driWaitForVBlank+0xd8) [0x5c5bfc]
15: /usr/lib/dri/i915_dri.so(intelSwapBuffers+0x262) [0x5d519c]
16: /usr/lib/dri/i915_dri.so [0x5c5d76]
17: /usr/lib/xorg/modules/extensions//libglx.so [0x470454]
18: /usr/lib/xorg/modules/extensions//libglx.so [0x462cfe]
19: /usr/lib/xorg/modules/extensions//libglx.so [0x46663a]
20: /usr/bin/Xorg(Dispatch+0x34f) [0x8085e6f]
21: /usr/bin/Xorg(main+0x47d) [0x806b6ed]
22: /lib/libc.so.6(__libc_start_main+0xe5) [0x1cf6d5]
23: /usr/bin/Xorg [0x806aad1]
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
(repeat last two lines over and over)
Comment 3 Will Woods 2008-11-02 21:42:14 EST
Created attachment 322256 [details]
full Xorg.0.log after (temporary) lockup
Comment 4 Jarod Wilson 2008-11-07 13:27:33 EST
Possibly related to bug 464866.
Comment 5 Youknowwho 2008-11-12 07:46:16 EST
It's definitely related to bug 464866, i have an Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller rev 3, and the same bug affects my suspend and hibernate functions on my laptop with compiz enabled, when I resume I get a black screen with a cursor and that's about it, it seems to only affect intel cards.
Comment 6 STEPHAN Gael 2008-11-12 08:26:39 EST
I have the same issue with a Dell Mini9 (intel gma950), only happens with compiz.

Software versions:

xorg-x11-drv-i810-2.5.0-3.fc10.i386
xorg-x11-server-Xorg-1.5.2-12.fc10.i386
kernel-2.6.27.5-94.fc10.i686
Comment 7 Thomas J. Baker 2008-11-12 08:59:19 EST
*** Bug 466995 has been marked as a duplicate of this bug. ***
Comment 8 Thomas J. Baker 2008-11-12 09:18:49 EST
I'm having the same issues. The machine is not locked up though and is
accessible via the network. It seems to eventually fix itself though the time
has never been less than 15 minutes before the unlock screen finally presents
itself. My logs show 

(II) AT Translated Set 2 keyboard: Device reopened after 1 attempts.
(II) Sleep Button (CM): Device reopened after 1 attempts.
(II) Macintosh mouse button emulation: Device reopened after 1 attempts.
(II) Power Button (CM): Device reopened after 1 attempts.
(II) Video Bus: Device reopened after 1 attempts.
(II) Video Bus: Device reopened after 1 attempts.
(II) Video Bus: Device reopened after 1 attempts.

when it eventually does come back.
Comment 9 Ben Gamari 2008-11-18 13:34:57 EST
Created attachment 323943 [details]
Keith's patch fixing vblank counter tracking

kpackard just posted a patch for this earlier this morning. It seems that mesa wasn't taking into account the reset frame counter after the mode switch. I've attached it.
Comment 10 Jarod Wilson 2008-11-18 15:40:26 EST
Patched into kernel-2.6.27.5-119.fc10, tested successfully by a few folks already (local build, not in koji just yet, should be tonight, I'd guess).
Comment 11 Jarod Wilson 2008-11-18 21:21:04 EST
MUCH better results on my t61. Doing an i686 build now to test on my AAO...
Comment 12 Ben Gamari 2008-11-18 21:35:37 EST
The patched has fixed the issue in my case as well. Suspend and resume work exactly as they should.
Comment 13 Jarod Wilson 2008-11-18 23:28:49 EST
okay, i686 build, suspend and resume works again on my aspire one too
Comment 14 Sachin Garg 2008-11-18 23:34:58 EST
suspend and resumes only works for first time. If I try second time I get a blank screen.
Comment 15 Jarod Wilson 2008-11-19 00:04:26 EST
Multiple (okay, only two so far) suspend and resumes work on both my thinkpad t61 (x86_64) and my acer aspire one (i686).
Comment 16 Tim Lauridsen 2008-11-22 01:58:01 EST
Installing the 2.6.27.5-120.fc10.i686 from koji

https://koji.fedoraproject.org/koji/buildinfo?buildID=70169

Solved the issue for me :)
Comment 17 Bojan Smojver 2008-11-23 15:57:35 EST
Dell Inspiron 6400 here. Similar problem, but with hibernate/thaw instead of suspend/resume. Black screen with mouse that moves, but that's about it.
Comment 18 Bojan Smojver 2008-11-23 17:22:07 EST
Indeed -120 helps here as well (on two Dell Inspirons 6400).

BTW, another system I have (Shuttle K45) that is based on Intel graphics as well, but running in runlevel 3, is now also working better. On that one, a logout from the text console would not bring back the login prompt. Now it does.
Comment 19 Bug Zapper 2008-11-25 22:56:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 Fedora Update System 2008-11-27 21:19:10 EST
kernel-2.6.27.7-130.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kernel-2.6.27.7-130.fc10
Comment 21 Fedora Update System 2008-12-06 23:16:50 EST
kernel-2.6.27.7-134.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10772
Comment 22 Fedora Update System 2008-12-09 06:36:39 EST
kernel-2.6.27.7-134.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Eric Donkersloot 2009-01-30 16:05:47 EST
Still having this issue:

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x3b) [0x812bc5b]
1: /usr/bin/Xorg(mieqEnqueue+0x289) [0x810b379]
2: /usr/bin/Xorg(xf86PostMotionEventP+0xc2) [0x80d4262]
3: /usr/bin/Xorg(xf86PostMotionEvent+0x68) [0x80d43c8]
4: /usr/lib/xorg/modules/input//evdev_drv.so [0x203d25]
5: /usr/bin/Xorg [0x80bcdb7]
6: /usr/bin/Xorg [0x80ac91e]
7: [0xf5c400]
8: [0xf5c416]
9: /lib/libc.so.6(ioctl+0x19) [0x316979]
10: /usr/lib/libdrm.so.2 [0x3b3a6cf]
11: /usr/lib/libdrm.so.2(drmWaitVBlank+0x28) [0x3b3ae08]
12: /usr/lib/dri/i965_dri.so [0x199578]
13: /usr/lib/dri/i965_dri.so(driWaitForVBlank+0xd8) [0x199798]
14: /usr/lib/dri/i965_dri.so(intelSwapBuffers+0x262) [0x19f5ac]
15: /usr/lib/dri/i965_dri.so [0x199912]
16: /usr/lib/xorg/modules/extensions//libglx.so [0x153504]
17: /usr/lib/xorg/modules/extensions//libglx.so [0x145cfe]
18: /usr/lib/xorg/modules/extensions//libglx.so [0x14963a]
19: /usr/bin/Xorg(Dispatch+0x34f) [0x8085e9f]
20: /usr/bin/Xorg(main+0x47d) [0x806b71d]
21: /lib/libc.so.6(__libc_start_main+0xe5) [0x2516e5]
22: /usr/bin/Xorg [0x806ab01]
[mi] mieqEnequeue: out-of-order valuator event; dropping.


00:02.1 Display controller: Intel Corporation Cantiga Integrated Graphics
Controller (rev 07)

2.6.27.12-170.2.5.fc10.i686
xorg-x11-drv-i810-2.5.0-4.fc10.i386
xorg-x11-server-Xorg-1.5.3-6.fc10.i386
Comment 24 Guil Barros 2009-04-02 10:04:09 EDT
This issue is still around but it seems that people confuse it with https://bugzilla.redhat.com/show_bug.cgi?id=464866

Granted it could be the same thing...

Disabling compiz seems to solve it.

-Guil

Note You need to log in before you can comment on or make changes to this bug.