Bug 467341 - buildinstall calls createrepo even when not needed
buildinstall calls createrepo even when not needed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Radek Vykydal
Alexander Todorov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 18:03 EDT by Dennis Gregorovic
Modified: 2009-01-20 16:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:37:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gregorovic 2008-10-16 18:03:06 EDT
/usr/lib/anaconda-runtime/buildinstall

There's a call to createrepo, but this call is only needed when the script is called with --pkgorder.  Testing for this and skipping the call when --pkgorder isn't used will cut down the runtime by a very significant percentage (50% or more).
Comment 1 Radek Vykydal 2008-10-23 10:40:04 EDT
The change seems trivial but I am not sure (because I don't know
where and how buildinstall is used) about the assumption that
createrepo is needed to be called only when --pkgorder is used.
Can you just assure me that it is so?

(Dan Mach thinks that wrt to the usage of buildinstall,
not running createrepo shouldn't break anything.)
Comment 2 Dennis Gregorovic 2008-10-23 11:06:36 EDT
I'm not a buildinstall expert, but my comment about createrepo was based on a scan of the sources, so I am fairly confident in it.  It's also something that we can test easily once we have a build with the change.
Comment 6 Radek Vykydal 2008-10-29 06:10:04 EDT
Modified, will be included in 11.1.2.150.
Comment 9 Alexander Todorov 2008-11-11 04:26:37 EST
Dennis,
can you confirm that everything is working as expected and the changes reduced compose time? Thanks.
Comment 10 Dennis Gregorovic 2008-11-11 14:12:37 EST
Yes, it appears that the changes worked. Below are the times (in seconds) that the buildinstall runs took before and after the change.  Thanks!

# anaconda-11.1.2.145-1
$ ./bin/profile distill-RHEL5.3-Server-20081020.1.log | grep buildinstall
create_buildinstall (arch=i386): 1748
create_buildinstall (arch=x86_64): 2484
create_buildinstall (arch=s390x): 2663
create_buildinstall (arch=ppc): 3119
create_buildinstall (arch=ia64): 3959

# anaconda-11.1.2.154-1
$ ./bin/profile distill-RHEL5.3-Server-20081105.1.log | grep buildinstall
create_buildinstall (arch=x86_64): 493
create_buildinstall (arch=ppc): 717
create_buildinstall (arch=i386): 724
create_buildinstall (arch=s390x): 970
create_buildinstall (arch=ia64): 971
Comment 13 errata-xmlrpc 2009-01-20 16:37:41 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0164.html

Note You need to log in before you can comment on or make changes to this bug.