Bug 467360 - SELinux is preventing the totem from using potentially mislabeled files (./.recently-used.xbel).
SELinux is preventing the totem from using potentially mislabeled files (./.r...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-16 23:53 EDT by Alex Chiang
Modified: 2008-10-27 10:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 10:00:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Chiang 2008-10-16 23:53:41 EDT
Summary:

SELinux is preventing the totem from using potentially mislabeled files
(./.recently-used.xbel).

Detailed Description:

SELinux has denied totem access to potentially mislabeled file(s)
(./.recently-used.xbel). This means that SELinux will not allow totem to use
these files. It is common for users to edit files in their home directory or tmp
directories and then move (mv) them to system directories. The problem is that
the files end up with the wrong file context which confined applications are not
allowed to access.

Allowing Access:

If you want totem to access this files, you need to relabel them using
restorecon -v './.recently-used.xbel'. You might want to relabel the entire
directory using restorecon -R -v '.'.

Additional Information:

Source Context                unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                ./.recently-used.xbel [ file ]
Source                        totem
Source Path                   /usr/bin/totem
Port                          <Unknown>
Host                          ethanol
Source RPM Packages           totem-2.24.2-2.fc10
Target RPM Packages           
Policy RPM                    selinux-policy-3.5.12-2.fc10
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   home_tmp_bad_labels
Host Name                     ethanol
Platform                      Linux ethanol 2.6.27-13.fc10.i686 #1 SMP Wed Oct
                              15 02:06:26 EDT 2008 i686 i686
Alert Count                   2
First Seen                    Thu 16 Oct 2008 09:43:50 PM MDT
Last Seen                     Thu 16 Oct 2008 09:49:24 PM MDT
Local ID                      e270c125-f8db-484b-ae99-b197135b841b
Line Numbers                  

Raw Audit Messages            

node=ethanol type=AVC msg=audit(1224215364.200:235): avc:  denied  { setattr } for  pid=4896 comm="totem" name=".recently-used.xbel" dev=dm-0 ino=2154664 scontext=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=ethanol type=SYSCALL msg=audit(1224215364.200:235): arch=40000003 syscall=15 success=no exit=-13 a0=9a5ede0 a1=180 a2=7c7ccc a3=2 items=0 ppid=4895 pid=4896 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="totem" exe="/usr/bin/totem" subj=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 key=(null)
Comment 1 Daniel Walsh 2008-10-17 16:10:58 EDT
Dont audit this.

Fixed in selinux-policy-3.5.13-1.fc10

Note You need to log in before you can comment on or make changes to this bug.