Bug 467362 - Can't play music on amarok and watch a movie on dragon, the first locks audio device
Can't play music on amarok and watch a movie on dragon, the first locks audio...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 00:06 EDT by Edney Matias
Modified: 2008-10-24 16:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 16:40:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edney Matias 2008-10-17 00:06:30 EDT
Description of problem: Running KDE Live CD with all updates applied. Right now with my normal user I can't watch a movie and listen to music. The first application locks the audio device. If i run as root I can do that flawless. If i log on gnome with my normal user I also can do that. What's wrong with KDE?


Version-Release number of selected component (if applicable): Running 
kde 4.1.2
xine-lib-pulseaudio-1.1.15-1.fc10.1.x86_64
kde-settings-pulseaudio-4.0-29.fc10.noarch
pulseaudio-core-libs-0.9.13-2.fc10.x86_64
pulseaudio-libs-0.9.13-2.fc10.x86_64
alsa-plugins-pulseaudio-1.0.18-1.rc3.fc10.x86_64
pulseaudio-0.9.13-2.fc10.x86_64
pulseaudio-module-x11-0.9.13-2.fc10.x86_64
Linux r2d2 2.6.27-13.fc10.x86_64 #1 SMP Wed Oct 15 01:50:46 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

How reproducible: Always


Steps to Reproduce:
1. Logged as a normal use in KDE, open amarok and start playing music
2. then open dragon and find a movie to watch
3. there is no movie sound, only music coming from amarok
  
Actual results: Amarok locks the sound device.


Expected results: I think pulse audio would enable me to achieve that!


Additional info: I also get ticks on sound, especially on the beginning of a track on amarok for example.
Comment 1 Rex Dieter 2008-10-17 08:55:25 EDT
Tried debugging this in #fedora-qa , but I was unable reproduce the problem.

(Seems) like pulseaudio isn't running. ?

When this happens, open a terminal or konsole, what does:
ps aux | grep pulseaudio
say?
Comment 2 Edney Matias 2008-10-18 02:02:05 EDT
Hi there,

writing to let you know that after Friday updates audio is now working. I can open amarok and dragon player for example and both produces audio at the same time. Can't achieve this with amarok and Flash player on Firefox, but I'm running preview of Flash 10, so it's fine here.

Thank you.
Comment 3 Lennart Poettering 2008-10-24 16:40:48 EDT
Closing.

Note You need to log in before you can comment on or make changes to this bug.