Bug 467386 - (CVE-2008-4579) CVE-2008-4579 cman/fence: insecure temporary file usage in the apc fence agents
CVE-2008-4579 cman/fence: insecure temporary file usage in the apc fence agents
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
http://nvd.nist.gov/nvd.cfm?cvename=C...
source=gentoo,reported=20081008,publi...
: Security
Depends On: 469338 519689
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 05:15 EDT by Tomas Hoger
Modified: 2016-03-04 05:56 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-17 09:31:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Hoger 2008-10-17 05:15:05 EDT
Common Vulnerabilities and Exposures assigned an identifier CVE-2008-4579 to the following vulnerability:

The (1) fence_apc and (2) fence_apc_snmp programs, as used in (a)
fence 2.02.00-r1 and possibly (b) cman, when running in verbose mode,
allows local users to append to arbitrary files via a symlink attack
on the apclog temporary file.

References:
http://bugs.gentoo.org/show_bug.cgi?id=240576
http://www.openwall.com/lists/oss-security/2008/10/13/3
Comment 1 Tomas Hoger 2008-10-17 05:16:38 EDT
Issue affects fence packages in the Red Hat Cluster Suite for Red Hat Enterprise Linux 4, and cman packages in the Red Hat Enterprise Linux 5.

Affected log file - /tmp/apclog - is no longer created by the current git version of apc fencing agents:
http://git.fedorahosted.org/git/cluster.git?p=cluster.git;a=tree;f=fence/agents;hb=HEAD
Comment 2 Fabio Massimo Di Nitto 2008-10-17 07:50:43 EDT
It also affects cman packages in Fedora9 and the whole cluster-2.03 release.
Backport from master will be available in the 2.03 series at the beginning of next week.

The 2.99.xx releases are also affected for fence_apc_snmp for all releases prior to 2.99.07 (not affected).

Fabio
Comment 3 Fedora Update System 2008-10-23 12:36:08 EDT
rgmanager-2.03.08-1.fc9, gfs2-utils-2.03.08-1.fc9, cman-2.03.08-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 errata-xmlrpc 2009-09-02 07:06:03 EDT
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5

Via RHSA-2009:1341 https://rhn.redhat.com/errata/RHSA-2009-1341.html
Comment 7 errata-xmlrpc 2011-02-16 11:14:18 EST
This issue has been addressed in following products:

  CLuster Suite for RHEL 4

Via RHSA-2011:0266 https://rhn.redhat.com/errata/RHSA-2011-0266.html

Note You need to log in before you can comment on or make changes to this bug.