Bug 467430 - No text ttys after suspend/resume
No text ttys after suspend/resume
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 467634 (view as bug list)
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-17 09:13 EDT by Mads Kiilerich
Modified: 2008-10-27 15:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 12:42:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (130.82 KB, application/octet-stream)
2008-10-20 05:06 EDT, Mads Kiilerich
no flags Details
/var/log/messages from session with boot, tty2 works, suspend, resume, tty2 doesn't work (94.90 KB, application/octet-stream)
2008-10-20 05:10 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2008-10-17 09:13:20 EDT
Description of problem:

After resume the ttys on ctrl-alt-f2 etc doesn't work - the screen is blank. Switching back to X on tty1 works fine.

As described on Bug 467429 it is with nomodeset (and thus textual boot sequence); without nomodeset suspend doesn't work at all.

01:00.1 Display controller: ATI Technologies Inc RV516 [Radeon X1300 Pro]
(Secondary)
in Dell OptiPlex 745

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.9.0-27.fc10.i386
kernel-2.6.27-13.fc10.i686

How reproducible:
100%
Comment 1 Matěj Cepl 2008-10-17 19:50:21 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Mads Kiilerich 2008-10-20 05:06:24 EDT
Created attachment 320855 [details]
Xorg.0.log

I am running with xorg.conf and thus autodetects ati / radeon.
Comment 3 Mads Kiilerich 2008-10-20 05:10:57 EDT
Created attachment 320857 [details]
/var/log/messages from session with boot, tty2 works, suspend, resume, tty2 doesn't work

I notice
Oct 20 10:51:37 dev-mk kernel: Suspending console(s) (use no_console_suspend to debug)
but have no clue if it is related ...
Comment 4 Mads Kiilerich 2008-10-23 12:42:09 EDT
I confirm that ttys works after suspend/resume with
kernel-2.6.27.3-39.fc10.i686 nomodeset
xorg-x11-drv-ati-6.9.0-30.fc10.i386

Closing
Comment 5 Bill Nottingham 2008-10-27 15:32:26 EDT
*** Bug 467634 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.