Bug 467431 - Inkscape unusable because colors have their values limited to 245
Inkscape unusable because colors have their values limited to 245
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 09:13 EDT by Philippe Rigault
Modified: 2008-10-18 15:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: inkscape-0.46-6.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-18 15:41:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Rigault 2008-10-17 09:13:35 EDT
Description of problem:
It is no longer possible to set colors correctly in Inkscape.
As a result, most colors are unavailable (including the basic ones as white, yellow, etc.) and Inkscape is totally unusable.

This is because the maximum value for any color slider is 245, which is enforced by to GTK+ >= 2.13.

This is well described in:
https://bugs.launchpad.net/ubuntu/+source/inkscape/+bug/257685
https://bugs.launchpad.net/inkscape/+bug/262681

GTK folks claim this is correct behaviour:
Copied from gnome bugzilla:
------- Comment #1 from Matthias Clasen 2008-09-04 00:47 UTC -------
 GTK+ is simply enforcing documented behaviour now. The fix is to set page_size
 to 0 when using adjustments for simple scalar values, such as in a slider.

>From the release notes: 
* GtkAdjustment now enforces that values are restricted to the
   range [lower, upper - page_size]. This has always been the documented
   behaviour, and the recommended practice is to set page_size to 0
   when using adjustments for simple scalar values, like in a slider
   or spin button.

Version-Release number of selected component (if applicable):
inkscape-0.46-5.fc10.x86_64

How reproducible: Always


Steps to Reproduce:
1. Open Inkscape
2. Create an object
3. Try to set its color to white (or any color with a value of >245 in any of its components.
  
Actual results:
Maximum value of all components is 245.
Standard colors are unavailable.

Expected results:
Being able to set values from 0 to 255 included.


Additional info:
Fixed in Ubuntu:
https://bugs.launchpad.net/ubuntu/+source/inkscape/+bug/257685/comments/9
Comment 1 Lubomir Rintel 2008-10-17 13:03:46 EDT
Thanks for the report!

Should be fixed in inkscape-0.46-6.fc10. Please test and let me knows if it fixes the issue for you.
Comment 2 Philippe Rigault 2008-10-18 15:41:23 EDT
Fixed indeed.

Thank you very much for your _rapid_ response.

Note You need to log in before you can comment on or make changes to this bug.