Bug 467438 - Flash Player blocked by SELinux on NFS home directories
Flash Player blocked by SELinux on NFS home directories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 10:17 EDT by Thomas Cameron
Modified: 2008-10-17 11:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-17 11:15:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Cameron 2008-10-17 10:17:50 EDT
Description of problem:
Running F10 beta x86_64, I installed the latest Flash player from Adobe (flash-plugin-10.0.12.36-release.i386).  SELinux blocked me from hearing any sound.  audit2why gave me:

[root@case ~]# audit2why -i /var/log/audit/audit.log 
type=AVC msg=audit(1224250708.604:353): avc:  denied  { read } for  pid=24270 comm="npviewer.bin" name="70bdfe81117ed4ee5e56a93d48f73bd9:runtime" dev=0:13 ino=16646214 scontext=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:nfs_t:s0 tclass=lnk_file

	Was caused by:
		Missing type enforcement (TE) allow rule.

		You can use audit2allow to generate a loadable module to allow this access.

audit2allow gave me:

module local 1.0;

require {
	type nsplugin_t;
	type nfs_t;
	class lnk_file read;
}

#============= nsplugin_t ==============
allow nsplugin_t nfs_t:lnk_file read;

After loading that that, I was able to hear audio.
Comment 1 Daniel Walsh 2008-10-17 11:15:27 EDT
Fixed in selinux-policy-3.5.13-1.fc10

Note You need to log in before you can comment on or make changes to this bug.