Bug 467471 - Cumin Graphs don't appear in Safari
Cumin Graphs don't appear in Safari
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
1.1
All All
high Severity high
: ---
: ---
Assigned To: Justin Ross
Jeff Needle
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 12:36 EDT by William Henry
Modified: 2011-08-12 12:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-08 11:58:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Henry 2008-10-17 12:36:27 EDT
Description of problem:

The throughput graphs for an individual queue are not showing up. Safari doesn't know what to do with them. There is no prompt for a plugin. 

Justin: " it's very likely a javascript compat issue."

This is important because Disney and Dreamworks have a lot of Macs and will be looking at Cumin using their Macs.  (They may use Firefox but they will also likely use Safari).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 William Henry 2008-10-17 14:34:09 EDT
Actually it is not just Safari but also FireFox  3.0.2.

With Firefox it is a bit different. There is a quick flash of the graph but then they disappear and show the string "stats". The flash happens every 3 seconds or so.
Comment 2 Justin Ross 2008-10-17 14:53:59 EDT
APPLICATION ERROR

----- python trace -----
Traceback (most recent call last):
  File "/home/cumin/mgmt/cumin/python/wooly/server.py", line 113, in service
    response = page.render(session)
  File "/home/cumin/mgmt/cumin/python/wooly/__init__.py", line 235, in render
    string = self.do_render(session, *args)
  File "/home/cumin/mgmt/cumin/python/cumin/stat.py", line 242, in do_render
    chart.plot_x_axis(x_intervals, x_step)
  File "/home/cumin/mgmt/cumin/python/cumin/charts.py", line 95, in plot_x_axis
    cr.show_text(text)
MemoryError

As it turns out, this is just a plain old charts exploding bug.  It appears this may be happening because fonts are not installed, as is suggested in this bug:

http://www.lorenzogil.com/projects/pycha/ticket/2
Comment 3 William Henry 2008-10-17 15:34:07 EDT
So I've changed the platform and OS selection above to All and All. This wasn't a Mac issue just bad timing when I decided to check the UI on my Mac.
Comment 4 Justin Ross 2008-11-09 23:34:21 EST
I've addressed this in the newest package, cumin-0.1.2751-1.el5.
Comment 5 Justin Ross 2009-01-08 11:58:37 EST
I can vouch that this dep is now in the rpm.

Note You need to log in before you can comment on or make changes to this bug.