Bug 467473 - [1855324] KDE/gnome do not recognize sxw and odt files
[1855324] KDE/gnome do not recognize sxw and odt files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: shared-mime-info (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Bastien Nocera
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 12:43 EDT by Alan Matsuoka
Modified: 2009-04-14 17:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 17:28:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Matsuoka 2008-10-17 12:43:15 EDT
Description of problem:

In RHEL 4, OpenOffice files do not open correctly in KDE.  This occurs with both sxw and odt files.  

How reproducible:
Always

Steps to Reproduce:
1) Open KDE or gnome
2) Try to open odt or sxw file with nautilus or konqueror

Actual results:
Opens odt file as an archive
Prompt for application for sxw file

Expected results:
oowriter should open

Additional info:
It looks like the file types are not in the /usr/share/magic and in /usr/share/mimelnk/applications/

This does work in RHEL 5, and by copying the openoffice info in /usr/share/magic/ and creating a .desktop file, I am able to have it recognize the sxw file.

This may not be a bug for RHEL 4 and odt files, since oowriter can read odt files, but not save as them.  However, since the default file type for oowriter is sxw, it should work for that

SEG Notes:

Looks like changes are needed in 2 packages.. file and kdelibs ?
Comment 1 Ngo Than 2009-04-14 17:28:56 EDT
it's a bug in shared-mime-info and it's fixed in 0.15-10.2

Note You need to log in before you can comment on or make changes to this bug.