Bug 467474 - Fedora 10 Beta fails to install on JS22
Fedora 10 Beta fails to install on JS22
Status: CLOSED DUPLICATE of bug 467311
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
ppc64 All
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 12:53 EDT by IBM Bug Proxy
Modified: 2008-10-20 05:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 05:52:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install.log from failed installation (49.44 KB, application/octet-stream)
2008-10-17 12:53 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2008-10-17 12:53:27 EDT
=Comment: #0=================================================
When trying to install Fedora 10 Beta into a LPAR on a JS22 blade, system fails to boot from the
installed disk.

Here are the steps I used to do this :

1. boot LPAR from DVD iso image.
2. at yaboot prompt, choose linux (default)
3. follow the normal installation process, that is
  - configure disks
  - select timezone
  - select packages to be installed
  - ...
4. install packages onto disk
5. installation ends with a window offering to reboot.

6. reboot

After reboot firmware fails to detect hardware. This is due to an empty PReP partition.
When attaching the disk to a different to find out what had actually gone wrong I found a
(at best) incomplete installation :

 - a lot of packages were missing
 - some were installed incompletely

In the installation log I found the following messages :

Installing glibc-2.8.90-12.ppc
Inconsistency detected by ld.so: dl-close.c: 719: _dl_close: Assertion `map->l_init_called' failed!
error: %post(glibc-2.8.90-12.ppc) scriptlet failed, exit status 127
Installing zlib-1.2.3-18.fc9.ppc

Not only for glibc but for a lot of other packages installed after glibc. I will attach a full log
to this bug.
In my interpretation the root cause for this seems to be in some problem in glibc on power6 and
everything after that is just a symptom of an incomplete installation.

So maybe this bug should rather be "glibc breaks installation on power6" ?
=Comment: #1=================================================
Jens Osterkamp <jens@de.ibm.com> - 

install.log from failed installation


=Comment: #2=================================================
Maybe I should add that RHEL5u2 is running in a different LPAR on the same machine without problems.
I also have Fedora 10 Beta running on a different (QS2x) cell blade without problems.

I conclude it must be something unique to this machine (JS22).
Comment 1 IBM Bug Proxy 2008-10-17 12:53:35 EDT
Created attachment 320696 [details]
install.log from failed installation
Comment 2 Jakub Jelinek 2008-10-20 05:52:15 EDT

*** This bug has been marked as a duplicate of bug 467311 ***

Note You need to log in before you can comment on or make changes to this bug.