Bug 467482 - sealert should exit if setroubleshoot isn't running
sealert should exit if setroubleshoot isn't running
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 13:38 EDT by Jeremy Katz
Modified: 2009-09-14 15:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-14 15:45:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2008-10-17 13:38:44 EDT
If setroubleshoot isn't running, sealert should probably exit to save resources
Comment 1 Daniel Walsh 2008-10-17 15:27:19 EDT
The problem is what happens when someone 

# service setroubleshoot restart

I guess the real goal would be to make the applet a lot less of a resource hog.  If we just rewrote the applet in C and then launched the python browser when someone clicked on it, would that save lots of memory?

Patches accepted. :^)

I also don't believe it should be running on all desktops, for managed desktops the applet should probably not run at all.
Comment 2 Jeremy Katz 2008-10-17 15:36:46 EDT
If they start setroubleshoot after they've already logged in, then they get sealert on the next login.  It doesn't really feel like a case to optimize for :)
Comment 3 Daniel Walsh 2008-10-17 17:59:09 EDT
One problem with that is we want to move to a dbus type service.  

Avc comes in, audit starts setroubleshoot and sealert gets notified.
Comment 4 Daniel Walsh 2008-10-17 17:59:39 EDT
THe real problem is that applets should be light weight.
Comment 7 Tom "spot" Callaway 2009-09-14 12:08:56 EDT
Dan, are there any plans to resolve this? If not, please close WONTFIX.
Comment 8 Daniel Walsh 2009-09-14 15:45:21 EDT
sealert is now a lightweight applet that starts setroubleshoot on demand.
So I would say this is fixed in F11.

Note You need to log in before you can comment on or make changes to this bug.