Bug 467529 - Pull components dependent on perl out of main postfix package?
Pull components dependent on perl out of main postfix package?
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 20:26 EDT by W. Michael Petullo
Modified: 2009-02-25 11:28 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.5.6-1.fc9
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-20 09:26:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2008-10-17 20:26:29 EDT
Description of problem:
I am working to make the dependencies of a subset of Fedora's packages more fine-grained. I would like to try to pull the perl dependency out of the postfix package.

The postfix package requires perl because it includes /usr/sbin/qshape. Could this be added to a sub-package (e.g., postifx-queuetools) or rewritten in C?

Version-Release number of selected component (if applicable):
postfix-2.5.1-2.fc9.i386

How reproducible:
Every time

Steps to Reproduce:
Notice postfix requires perl.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matěj Cepl 2008-11-12 21:33:22 EST
Actually, a real man could rewrite the script in bash, I think. Not that I would have a time and wish to do so.
Comment 2 W. Michael Petullo 2008-11-13 17:43:17 EST
You are absolutely right. I am (very) slowly trying to do just that...or cheating and finding C implementations done by others.
Comment 3 Miroslav Lichvar 2008-11-14 04:41:37 EST
I'm preparing a subpackage for the script.
Comment 4 Miroslav Lichvar 2008-11-20 09:26:31 EST
postfix-2.5.5-2.fc11 now has -perl-scripts subpackage which contains qshape and pflogsumm scripts.
Comment 5 Fedora Update System 2008-11-20 09:30:51 EST
postfix-2.5.5-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/postfix-2.5.5-2.fc10
Comment 6 Fedora Update System 2008-11-20 09:35:14 EST
postfix-2.5.5-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/postfix-2.5.5-2.fc9
Comment 7 Fedora Update System 2009-02-25 11:27:30 EST
postfix-2.5.6-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-02-25 11:28:29 EST
postfix-2.5.6-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.