Bug 467529 - Pull components dependent on perl out of main postfix package?
Summary: Pull components dependent on perl out of main postfix package?
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: postfix
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-10-18 00:26 UTC by W. Michael Petullo
Modified: 2018-04-11 08:13 UTC (History)
4 users (show)

Fixed In Version: 2.5.6-1.fc9
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-20 14:26:31 UTC


Attachments (Terms of Use)

Description W. Michael Petullo 2008-10-18 00:26:29 UTC
Description of problem:
I am working to make the dependencies of a subset of Fedora's packages more fine-grained. I would like to try to pull the perl dependency out of the postfix package.

The postfix package requires perl because it includes /usr/sbin/qshape. Could this be added to a sub-package (e.g., postifx-queuetools) or rewritten in C?

Version-Release number of selected component (if applicable):
postfix-2.5.1-2.fc9.i386

How reproducible:
Every time

Steps to Reproduce:
Notice postfix requires perl.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matěj Cepl 2008-11-13 02:33:22 UTC
Actually, a real man could rewrite the script in bash, I think. Not that I would have a time and wish to do so.

Comment 2 W. Michael Petullo 2008-11-13 22:43:17 UTC
You are absolutely right. I am (very) slowly trying to do just that...or cheating and finding C implementations done by others.

Comment 3 Miroslav Lichvar 2008-11-14 09:41:37 UTC
I'm preparing a subpackage for the script.

Comment 4 Miroslav Lichvar 2008-11-20 14:26:31 UTC
postfix-2.5.5-2.fc11 now has -perl-scripts subpackage which contains qshape and pflogsumm scripts.

Comment 5 Fedora Update System 2008-11-20 14:30:51 UTC
postfix-2.5.5-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/postfix-2.5.5-2.fc10

Comment 6 Fedora Update System 2008-11-20 14:35:14 UTC
postfix-2.5.5-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/postfix-2.5.5-2.fc9

Comment 7 Fedora Update System 2009-02-25 16:27:30 UTC
postfix-2.5.6-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2009-02-25 16:28:29 UTC
postfix-2.5.6-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.