Bug 467549 - Gnome's System menu contains no entry for changing keyboard layout
Gnome's System menu contains no entry for changing keyboard layout
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-menus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-18 08:01 EDT by Răzvan Sandu
Modified: 2008-10-20 13:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-18 18:26:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-10-18 08:01:44 EDT
Description of problem:

Gnome's System menu contains no entry for an utility that changes keyboard layout (system-config-keyboard).

Version-Release number of selected component (if applicable):
gnome-menus-2.24.0-1.fc10.x86_64
gnome-menus-2.24.0-1.fc10.i386


How reproducible:
Always.

Steps to Reproduce:
1. Install stock Fedora 10 rawhide and online updates as of October 18, 2008
2. Open a session with Gnome desktop environment
3. Go to System menu -> Administration
  
Actual results:
There is no entry for an utility that allows setting up the keyboard layout.

Expected results:
Gnome menus should contain such an entry. The same is expected in KDE's menus.

Distro should provide standard utilities for changing keyboard layout in both X and text mode (command-line and/or ncurses-based).
Comment 1 Matthias Clasen 2008-10-18 18:26:07 EDT
System>Preferences>Hardware>Keyboard
Comment 2 Răzvan Sandu 2008-10-19 23:03:18 EDT
Hello,


Thanks A LOT and sorry for my omission !


A few questions still remain:

1. I'm a daily user of Fedora for years and I didn't noticed that the keyboard setting utility is there (System>Preferences>Hardware>Keyboard). Is is wise to bury it so deep in the menus, splitting it from the language setting utility ?

2. Do we have a 100% equivalent in KDE, AND, especially, in text mode ?

What's the *canonical* way an user should set his keyboard, if he runs in default runlevel 3 ? ("Canonical" = the procedure one would write in the formal Red Hat manuals...)

Thanks again,


Regards,
Răzvan
Comment 3 Jakub Jelinek 2008-10-20 13:18:56 EDT
*** Bug 466985 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.