Bug 467579 - Installer fails to connect with Broadcom BCM4401
Installer fails to connect with Broadcom BCM4401
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-18 16:54 EDT by Peter Lemieux
Modified: 2008-10-28 18:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 18:13:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Lemieux 2008-10-18 16:54:54 EDT
Description of problem:
During installtion, F10 beta does not connect to network either via DHCP or via static configuration.

Version-Release number of selected component (if applicable):


How reproducible:
During the installation.

Steps to Reproduce:
1. Run installer
2. Try to connect to network via DHCP or using static adderss
3.
  
Actual results:
does not connect

Expected results:
should connect

Additional info:
01:09.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)

After installation I can use system-config-network to connect successfully.
Comment 1 Peter Lemieux 2008-10-18 16:56:32 EDT
I've installed other Fedora versions from FC3 through F8 without encountering this problem.
Comment 2 Peter Lemieux 2008-10-18 16:57:57 EDT
Don't seem to be able to edit the last comment.  Just wanted to add that those installations were on the same hardware.  Dell Dimension 2400.
Comment 3 Harald Hoyer 2008-10-20 06:58:19 EDT
if s-c-network works, why is this a bug then?
Comment 4 Peter Lemieux 2008-10-20 11:06:26 EDT
It does not work *during installation*.  

When I tried to connect to additional repositories, it failed to secure a network connection.  I tried repeatedly using both DHCP and static assignments.  I thought it might have been a hardware failure (unlikely, though, since the machine worked fine before I tried upgrading) or a driver problem (which also doesn't seem true since s-c-network works after installation from the command line).

As I say, I've installed lots of copies of Fedora and never had a problem with this machine getting a network connection.  (I've often used NFS installs without a hitch, for instance.)  In this case I was installing from the DVD and found I was unable to connect when adding repositories at the end of the installation sequence.
Comment 5 Harald Hoyer 2008-10-21 07:59:33 EDT
assigning to anaconda due to "during installation".
Comment 6 David Cantrell 2008-10-21 19:21:56 EDT
Can you copy log files from /tmp (*.log) during installation and attach them to this bug?  Copy them to a USB flash drive or something similar.
Comment 7 Peter Lemieux 2008-10-22 17:34:48 EDT
You mean rerun the installer and capture them during the installation process?  Right now all I have is firstboot.X.log and an empty yum.log in /tmp and install.log and install.log.syslog in /root.  I take it there's some other log that gets written during installation and then deleted?  

If I can mount an NFS share as /tmp during installation I'll give that a try.  We had a USB key floating around here at one point, but I haven't seen it lately.  Any hints on what log I'm looking for and when I might be able to capture it?
Comment 8 David Cantrell 2008-10-22 23:25:44 EDT
If you can perform the installation again passing loglevel=debug as a boot: parameter, that would generate log files that are most useful to us.

The install.log and install.log.syslog files are the most useful to us.
Comment 9 David Cantrell 2008-10-28 18:13:41 EDT
If you can provide the data requested in comment #8, please reopen the bug and I'll take a look at it.

Note You need to log in before you can comment on or make changes to this bug.