Bug 467590 - Passsync.msi fails to receive sync updates in win2008 x86_64
Passsync.msi fails to receive sync updates in win2008 x86_64
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Sync Service (Show other bugs)
1.1.3
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
: 489021 (view as bug list)
Depends On:
Blocks: 389_1.2.4 639035
  Show dependency treegraph
 
Reported: 2008-10-18 21:09 EDT by Ken Barber
Modified: 2015-12-07 12:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:08:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Barber 2008-10-18 21:09:55 EDT
Description of problem:

passsync service doesn't seem to register password changes.


Version-Release number of selected component (if applicable): Passsync-20060330.msi


How reproducible:


Steps to Reproduce:
1. Install passsync on Windows 2008 x86_64 domain controller
2. Follow instructions for setup: http://directory.fedoraproject.org/wiki/Howto:WindowsSync
3. Attempt password change in 'Active Directory Users and Computers' ... ie. right-click and 'reset password'.
  
Actual results:

10/19/08 01:37:01: Password list is empty.  Waiting for passhook event

Expected results:

<<TIMESTAMP>> Received passhook event.  Attempting sync.

Additional info:

Only 105 events in log file ... I can see the password sync bind to Fedora DS successfully ... however I never see the logfile indicate that a passhook event has occurred.
Comment 1 Rich Megginson 2008-10-20 10:10:45 EDT
We have never tested passsync on a 64-bit system.  We only support 32-bit windows right now.  The code is open source, and the free visual studio compiler from microsoft can be used to compile the code.
Comment 2 Rich Megginson 2009-04-09 13:31:05 EDT
This falls under the category of "support 32-bit and 64-bit windows 2003 and 2008 for both passsync and windows console"
Comment 3 Rich Megginson 2009-04-09 14:58:07 EDT
*** Bug 489021 has been marked as a duplicate of this bug. ***
Comment 4 Rich Megginson 2009-11-04 12:21:44 EST
Fixed in PassSync 1.1.2
Comment 5 Ciro Iriarte 2010-10-21 11:17:47 EDT
We're testing Win2k8 R2 64bits with PassSync 1.1.4 and logs don't show any password change event..

I see from Comment 4 that this should work on 1.1.2, but the description says now that the bug affects 1.1.3
Comment 6 Rich Megginson 2010-10-21 11:30:01 EDT
(In reply to comment #5)
> We're testing Win2k8 R2 64bits with PassSync 1.1.4 and logs don't show any
> password change event..
> 
> I see from Comment 4 that this should work on 1.1.2, but the description says
> now that the bug affects 1.1.3

Did you see any errors during PassSync installation?

Did you restart the AD box after installing PassSync?

Do you see anything in the log - http://directory.fedoraproject.org/wiki/Howto:WindowsSync#PassSync_Logging ?
Comment 7 Ciro Iriarte 2010-10-21 14:40:50 EDT
There were no errors during installation... The Windows machine was restarted, we still see only "Waiting for passhook event"
Comment 8 Ciro Iriarte 2010-10-21 15:07:00 EDT
Log entries:

10/21/10 11:54:26: PassSync service initialized
10/21/10 11:54:26: PassSync service running
10/21/10 11:54:27: No entries yet
10/21/10 11:54:27: Password list is empty.  Waiting for passhook event
10/21/10 12:04:31: Received passhook event.  Attempting sync
10/21/10 12:04:31: No entries yet
10/21/10 12:04:31: PassSync service stopped
10/21/10 12:04:32: PassSync service initialized
10/21/10 12:04:32: PassSync service running
10/21/10 12:04:32: No entries yet
10/21/10 12:04:32: Password list is empty.  Waiting for passhook event


Looking at it right now it indeed lists an event. We tried again  to change a password, but there are no new events registered....

Is there a more verbose log level?
Comment 9 Ciro Iriarte 2010-10-21 15:34:13 EDT
Ok, the AD admin omitted the fact that there are more domain controllers in the lab. Leaving only this one (the one with PassSync) running made it catch all the updates.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.