Bug 467592 - Fedora 9 & 10 - SiS unable to acheive 24bpp at 1280x800
Fedora 9 & 10 - SiS unable to acheive 24bpp at 1280x800
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-sis (Show other bugs)
10
i686 Other
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-18 21:32 EDT by Kamisamanou Burgess
Modified: 2009-02-20 11:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 11:30:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the log file Xorg.0.log (32.58 KB, text/plain)
2008-11-28 01:10 EST, Kamisamanou Burgess
no flags Details
Xorg.conf created by Xorg server (43 bytes, text/plain)
2008-12-09 00:29 EST, Kamisamanou Burgess
no flags Details

  None (edit)
Description Kamisamanou Burgess 2008-10-18 21:32:03 EDT
Description of problem:
Doesn't display at 24bpp despite having the setting and reporting to be running at such color depth. Possibly related: GDM doesn't appear

Version-Release number of selected component (if applicable):
X Server: 1.5.0
X Protocol Version: 11
SiS Driver: latest as of 10-18-2008

How reproducible:
Limited to proper hardware, particularly that found in the Acer Aspire 3003WLCi

Steps to Reproduce:
1.Get proper hardware
2.Install Fedora 9
3.Boot the computer
  
Actual results:
Appearance of 16bpp@1280x800

Expected results:
Appearance of 24bpp@1280x800

Additional info:
Screenshots, attempts at repair, and background information can be found at:
http://forums.fedoraforum.org/showthread.php?t=200566
Comment 1 Matěj Cepl 2008-10-22 10:47:32 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Matěj Cepl 2008-11-24 11:13:25 EST
Reporter, could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 3 Kamisamanou Burgess 2008-11-24 17:08:00 EST
I am very sorry for not having replied sooner. I uninstalled the OS and haven't had the time to reinstall it yet. I plan on doing so over the holiday weekend if I don't get another computer. I will, within the month of November, reply with either the data requested, or a request to close the bug as INSUFFICIENT_DATA. I thank you very much.
Comment 4 Kamisamanou Burgess 2008-11-28 01:10:31 EST
Created attachment 324935 [details]
This is the log file Xorg.0.log

Here is the requested log file. I don't currently have a xorg.conf.
Comment 5 Kamisamanou Burgess 2008-11-28 13:09:33 EST
I'm not sure about whether or not this changes anything, but I also installed from a livecd.
Comment 6 Kamisamanou Burgess 2008-11-28 17:58:33 EST
I just plugged in the monitor from a desktop I have in the house. Everything appears just like it should on the extra monitor. The color problems don't occur on my monitor, but only because the resolution is lowered to accomodate both monitors.

I also thought worth pointing out that everything worked fine in Fedora 6-8 and the same problem resides in Fedora 10.
Comment 7 Kamisamanou Burgess 2008-11-29 10:51:31 EST
I've been looking for ways to create the requested xorg.conf, but am sadly in the dark. I've heard some say use system-config-display, but is that a good method?
Comment 8 Kamisamanou Burgess 2008-12-08 23:55:24 EST
I have, since reporting this bug, switched to Fedora 10. The problem is still identical and the previously attached Xorg.0.log is from my Fedora 10 installation. Therefore, I have modified the bug accordingly.
Comment 9 Kamisamanou Burgess 2008-12-09 00:29:46 EST
Created attachment 326268 [details]
Xorg.conf created by Xorg server
Comment 10 Kamisamanou Burgess 2009-01-07 21:36:31 EST
I have no clue what happened, but I just turned my computer on and the screen is picture perfect.
Comment 11 Kamisamanou Burgess 2009-01-07 23:11:46 EST
The graphics have messed up again. All I remember is that when they worked, the computer had turned off without shutting down, hibernating, etc. due to a dead battery. I then turned the computers on a full charge and several hours later and it worked. I downloaded the latest updates. I then shut it down, and restarted it to find the problem had resurfaced. I will attempt to recreate the solution by running the computer till the battery dies.
Comment 12 Kamisamanou Burgess 2009-02-20 11:30:14 EST
I have tested it multiple times and my graphics are now displaying properly. The problem was that at some times, the PanelDelayCompensation is not auto detected properly. Creating the necessary entries in xorg.conf fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.