This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 467597 - Brother HL-2140 printer does not print
Brother HL-2140 printer does not print
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-10-19 01:18 EDT by Yusuf Ma
Modified: 2013-08-25 13:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.0.3-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-12 21:31:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of '/usr/sbin/lpinfo -l -v' (1.30 KB, text/plain)
2008-10-21 23:25 EDT, Yusuf Ma
no flags Details

  None (edit)
Description Yusuf Ma 2008-10-19 01:18:45 EDT
Description of problem:
Brother HL-2140 printer can be recognized and configured after plugged in, but it can not print. The automatically configured driver is Brother HL-2170W Foomatic/pxlmono. When a print task is sent to printer, the LED light flashes and the fan inside the printer starts running. It looks like some data transferring to the printer. However, nothing happens after that.

Version-Release number of selected component (if applicable):
foomatic-3.0.2-67.fc10.i386

How reproducible:
Everytime

Steps to Reproduce:
1. Plug in the Brother HL-2140 printer
2. Wait for a few seconds until the system recognizes and configures the printer
3. Try to print something
  
Actual results:
Printer LED light flashes and the fan runs for a few seconds. Nothing printed after that.

Expected results:
Print the file.

Additional info:
This printer works on Fedora 9. It also works on Fedora 10 beta after installing the driver from Brother's website.
Comment 1 Tim Waugh 2008-10-21 11:06:25 EDT
Please attach the output of '/usr/sbin/lpinfo -l -v'.
Comment 2 Yusuf Ma 2008-10-21 23:25:58 EDT
Created attachment 321106 [details]
output of '/usr/sbin/lpinfo -l -v'
Comment 3 Tim Waugh 2008-10-22 11:46:56 EDT
Does the HL-1250 driver work for you?
Comment 4 Yusuf Ma 2008-10-22 22:52:47 EDT
Yes, HL-1250 driver works
Comment 5 Tim Waugh 2008-10-30 13:26:13 EDT
The problem is that foomatic is missing an entry for this printer pointing to the correct driver, so we have to guess a close match.
Comment 6 Bug Zapper 2008-11-25 22:59:46 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Fedora Update System 2009-10-22 12:01:12 EDT
foomatic-4.0.3-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/foomatic-4.0.3-1.fc10
Comment 8 Tim Waugh 2009-10-22 12:01:51 EDT
Please try out this test package when it becomes available and let me know whether it works for you.
Comment 9 Fedora Update System 2009-10-27 02:38:11 EDT
foomatic-4.0.3-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-10741
Comment 10 Fedora Update System 2009-11-06 19:23:10 EST
foomatic-4.0.3-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-10741
Comment 11 Fedora Update System 2009-11-10 12:49:15 EST
foomatic-4.0.3-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-10741
Comment 12 Fedora Update System 2009-11-12 21:31:17 EST
foomatic-4.0.3-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.