Bug 467623 - no access to T5 as user, works fine as root
no access to T5 as user, works fine as root
Status: CLOSED DUPLICATE of bug 466604
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-19 11:46 EDT by Patrick C. F. Ernzer
Modified: 2008-10-21 09:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 09:31:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of the devices that show up in hal-device when the Palm is connected. (3.71 KB, text/plain)
2008-10-19 11:46 EDT, Patrick C. F. Ernzer
no flags Details

  None (edit)
Description Patrick C. F. Ernzer 2008-10-19 11:46:00 EDT
Created attachment 320804 [details]
output of the devices that show up in hal-device when the Palm is connected.

Description of problem:
seems access to Palm devices is broken again, at least on my fedora box (fresh install of F10 Beta, then yum update to latest rawhide) for my Palm Tungsten T5

Version-Release number of selected component (if applicable):
$ rpm -q pilot-link libusb udev hal hal-info;uname -r
pilot-link-0.12.3-18.fc10.x86_64
libusb-0.1.12-19.fc10.x86_64
udev-127-2.fc10.x86_64
hal-0.5.12-3.20081013git.fc10.x86_64
hal-info-20081013-1.fc10.noarch
2.6.27.2-23.rc1.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
1. connect Palm
2. power on Palm
3. wait a while for device to settle
4. pilot-xfer -l
5. press hot-sync button
  
Actual results:
sits indefinitely at
   Listening for incoming connection on usb:...

Expected results:
connect and list my databases


Additional info:
a. if I do the same steps but step 4. as root it works, so we seem to have a permission problem. (as root does not have the port set via PILOTPORT I add '-p usb:')

b. $ env|grep PILOT
PILOTPORT=usb:

c. I have made no changes to any of pilot-link libusb udev hal hal-info (checked with rpm -V).

d. I have not enabled 60-libpisock.rules as I understand that PolicyKit makes it redundant.

e. org.freedesktop.hal.device-access.pda is set to
Anyone: No
Console: No
Active Console: Yes
and I am logged into gnome locally.

f. adding my user under explicit authorisations with 'always' does not help either (and should not be necessary anyway).

g. I'll attach the output of the devices that show up in hal-device when the Palm is connected.

h. The box is x86_64 so I set the arch explicitly, but it may very well affect all arches.
Comment 1 Kevin R. Page 2008-10-21 06:13:40 EDT
(Just to check we're starting from a known working point, you got this working on F9 in the end?)

Could you do a:

getfacl /dev/bus/usb/<usb bus used>/*

when the hotsync button is pressed and post the output, please?

Looking at your hal output I can't see a access_control.file set - this could be the source of the problems, unless the mechanism has changed in hal/policykit.

If this is a perms problem - and it looks like one - it should be re-filed against HAL/PolicyKit. The config was moved out of pilot-link and into those packages upstream.
Comment 2 Kevin R. Page 2008-10-21 06:21:24 EDT
Ahah, dup of bug #466604
Comment 3 Alex Lancaster 2008-10-21 09:31:59 EDT
Closing as a duplicate as per comment #2.  If it turns out to not match, feel free to re-open.

*** This bug has been marked as a duplicate of bug 466604 ***

Note You need to log in before you can comment on or make changes to this bug.