This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 467625 - No keyboard and mouse in X
No keyboard and mouse in X
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-19 11:57 EDT by Boyan Anastasov
Modified: 2008-10-21 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 03:01:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file from X with non working keyboard and mouse (39.41 KB, text/plain)
2008-10-19 12:06 EDT, Boyan Anastasov
no flags Details
diff file between 1.5.2-5.fc10 (non working) and 1.5.2-4.fc10 (working) keyboard and mouse (4.85 KB, text/plain)
2008-10-19 12:09 EDT, Boyan Anastasov
no flags Details

  None (edit)
Description Boyan Anastasov 2008-10-19 11:57:35 EDT
Description of problem:
No keyboard and mouse after upgrading to xorg-x11-server-Xorg-1.5.2-5.fc10.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.5.2-5.fc10

How reproducible:
Every time

Steps to Reproduce:
1. Start X with startx
  
Actual results:
Keyboard and mouse are not working (not present). Pressing any key or moving
the mouse does not produce anything.

Expected results:
As usual working keyboard and mouse.

Additional info:
Going back to xorg-x11-server-Xorg-1.5.2-5.fc10 everything is as expected.

The difference I see is this warning in Xorg.log:
(WW) AllowEmtpyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.

but there is no info how to disable this option. Tried to put it:

Option "AllowEmptyInput "off"

in sections - "ServerFlags", "InputDevice" (for keyboard and mouse), but it looks like the option is not recognized.
Comment 1 Boyan Anastasov 2008-10-19 12:06:42 EDT
Created attachment 320809 [details]
Xorg log file from X with non working keyboard and mouse
Comment 2 Boyan Anastasov 2008-10-19 12:09:16 EDT
Created attachment 320810 [details]
diff file between 1.5.2-5.fc10 (non working) and 1.5.2-4.fc10 (working) keyboard and mouse
Comment 3 Peter Hutterer 2008-10-19 18:41:34 EDT
You don't have HAL running? That should usually provide the list of input devices to the server.
Anyway, I tried to reproduce it with not success, works fine here both in ServerLayout and in a separate ServerFlags section.


Option "AllowEmptyInput "off"
could it be the missing " after AllowEmptyInput?
Comment 4 Boyan Anastasov 2008-10-20 03:01:09 EDT
No, X does not start if there is error in syntax.
Now I've tried again after reboot with this option, and everything works...
I'm sure I've tested it correctly in 3 sections.
OK, if something go wrong again I'll reopen this bug.
Closing it now, sorry for the noise.
Comment 5 Boyan Anastasov 2008-10-21 06:58:12 EDT
Finally found why the option is not working. There is a typo in the log message:
(WW) AllowEmtpyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.

AllowEmtpyInput
       ^^

I copied and pasted it in the config. That's why the option didn't worked for me... :)
Comment 6 Valdis Kletnieks 2008-10-21 20:27:07 EDT
The 'man xorg.conf' page says:

       Option "AllowEmptyInput" "boolean"
              If  enabled,  don’t add the standard keyboard and mouse drivers,
              if there are no input devices in the config file.   Disabled  by
              default.

But my logfile says:

(WW) AllowEmtpyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.

Between the manpage lying about the default, and the triple negative requiring massive mental effort to parse, it's hard to tell what's going on.

And my xorg.conf has:

Section "ServerLayout"
        Identifier "XFree86 Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

So there *are* input devices in the config file, so scratch that "if there are no input devices' qualifier.

Does anybody actually understand what the semantics of AllowEmptyInput are *supposed* to be?
Comment 7 Peter Hutterer 2008-10-21 20:51:11 EDT
My manpage says: 
"If enabled, don't add the standard keyboard and mouse drivers, if there are no
input devices in the config file.  Enabled by default if AutoAddDevices and
AutoEnableDevices is enabled, otherwise disabled."
I'll add another line warning about the disabling of mouse/kbd devices to the man page.

Anyway, the semantics are:

AllowEmptyInput is on:
- if there are no input devices in xorg.conf, don't do anything.
- ignore devices in xorg.conf that use the kbd and mouse driver (new)

AllowEmptyInput is off:
- add all devices listed in the xorg.conf
- if no devices are listed in the xorg.conf, add a default pointer + keyboard (/dev/console and /dev/input/mice usually)

On top of that, you have AutoAddDevices and AutoEnableDevices, who decide if devices listed by HAL should be added. The common defaults is for all three to be true, or (if HAL isn't an option for some reason) for all three to be false.

Note You need to log in before you can comment on or make changes to this bug.