Bug 467628 - Yum keeps older kernel packages but not older kernel-firmware packages
Yum keeps older kernel packages but not older kernel-firmware packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-19 12:35 EDT by Mathieu Bridon
Modified: 2014-01-21 18:06 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 10:49:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mathieu Bridon 2008-10-19 12:35:36 EDT
Description of problem:
The installonly plugin was merged in yum and allows to keep some versions of some packages when updating.

By default, the kernel package is kept in 3 versions.

However, in F10, the kernel package was split into a kernel and a kernel-firmware packages.

Yum should also be configured to keep the kernel-firmware package in 3 versions as booting an older kernel might not work if your hardware relies on some firmware in the kernel-firmware package.


Version-Release number of selected component (if applicable):
yum-3.2.19-5.fc10.noarch


How reproducible:
Always


Steps to Reproduce:
1. run yum update when there is a new kernel to update

  
Actual results:
The new kernel will be installed (eventually removing an older one) and the kernel-firmware package will be updated.


Expected results:
Both the new kernel and kernel-firmware packages should be installed only (eventually removing an older version of both of them).
Comment 1 James Antill 2008-10-19 14:06:51 EDT
Added kernel-firmware to the installonly list upstream, should be fixed for Fedora 10.
Comment 2 Jeremy Katz 2008-10-19 16:37:02 EDT
Adding it to installonly isn't really sufficient (or a good idea) as the kernel-firmware package isn't made to have multiple versions installed.  The files from different versions of the package are almost certain to have conflicts.
Comment 3 James Antill 2008-10-19 21:21:07 EDT
Ok, so -1 for me believing stuff would be sane.

So what's the next fix? It seems like Fedora should make sure kernel-firmware can be installed multiple times, no?

I can obviously revert the yum upstream change before Seth puts it into rawhide, but then it's still going to be broken for anyone that relies on it.

Is there another fix (like maybe having the kernel-firmware package be version neutral?

I'll reassign to the kernel-firmware package to see what they want to do.
Comment 4 David Woodhouse 2008-10-20 03:37:00 EDT
We don't keep multiple versions of _any_ of our firmware packages (iwl4965-firmware, ql2100-firmware, etc.). The kernel-firmware package is no different.

The firmware which is shipped on its own in those separate packages is much more likely to be under active development, while the firmware within the kernel package is from older drivers and is much less likely to receive changes.

So if we get away with having no 'roll-back' for the separate packages, we should definitely be OK with it for the kernel-firmware package.

The latest kernel-firmware package should always be sufficient; there's no need to install multiple versions of it.
Comment 5 James Antill 2008-10-20 09:35:55 EDT
Ok, I've reverted the yum change ... kernel-firmware isn't installonly anymore.

I guess that means you're going to close this not a bug, but I'll let you do it.
Comment 6 Mathieu Bridon 2008-10-20 09:55:10 EDT
Sorry for not being that smart, but I didn't really understand... :/

kernel-firmware and kernel are to be used together.

We keep 3 versions of kernel.

Why don't we keep 3 versions of kernel-firmware ?

For example, let's say I have a nvidia graphic card and I'm using the kmod-nvidia from "the other repository". If I keep 3 different kernels, I should keep 3 different kmods (one by kernel) as both are needed to use my computer.

Is there any difference in the case of the kernel-firmware package ?
Comment 7 David Woodhouse 2008-10-20 10:48:18 EDT
Yes, there is. You don't need multiple versions of the kernel-firmware package; the latest is fine. Just like all the _other_ firmware packages we have in Fedora (iwl4965-firmware, qla2xxx-firmware, libertas-firmware, etc.)

It's slightly confusing, I know, that we generate the kernel-firmware package as part of the kernel build. We'll be fixing that soon, and will decouple the version numbers. But it's purely cosmetic.

Note You need to log in before you can comment on or make changes to this bug.