Bug 467661 - libopenjpeg has undefined references
libopenjpeg has undefined references
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openjpeg (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-19 23:27 EDT by Alex Wauck
Modified: 2009-07-16 02:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.3-5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-16 02:51:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
config.log from poppler-0.10 (69.05 KB, application/octet-stream)
2008-10-19 23:27 EDT, Alex Wauck
no flags Details
Results of attempting to build from source RPM (1023 bytes, application/octet-stream)
2008-10-19 23:28 EDT, Alex Wauck
no flags Details
patch to force libm dependency at build (541 bytes, patch)
2009-03-18 14:09 EDT, Moritz Barsnick
no flags Details | Diff

  None (edit)
Description Alex Wauck 2008-10-19 23:27:14 EDT
Created attachment 320837 [details]
config.log from poppler-0.10

Description of problem:
Poppler 0.10 fails to use libopenjpeg because libopenjpeg has undefined references to floor, ceilf, floorf, lrintf, and pow.  Attempts to build the source RPM for libopenjpeg results in a failed patch.  I will attach relevant output to this bug.  Also, it would appear that the openjpeg packages have not been rebuilt since Fedora 9.


Version-Release number of selected component (if applicable):
1.3-2.fc9

How reproducible:
Attempt to configure poppler-0.10 (using source from poppler site).  Note that it does not use libopenjpeg (and advises you to use it).  Examine config.log and see that the libopenjpeg test program failed to compile due to the aforementioned undefined references.
Comment 1 Alex Wauck 2008-10-19 23:28:58 EDT
Created attachment 320838 [details]
Results of attempting to build from source RPM
Comment 2 Callum Lerwick 2008-10-20 13:26:45 EDT
Need to add -lm in there somewhere. As OpenJPEG doesn't have pkg-config support yet, I don't know what I can do from the OpenJPEG end, other than add it... Patches accepted. :)

Also it's not finding openjpeg.h since it should be looking in /usr/include/openjpeg/ ...
Comment 3 Bug Zapper 2008-11-25 23:01:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Dominik 'Rathann' Mierzejewski 2009-03-01 14:14:20 EST
(In reply to comment #2)
[...]
> Also it's not finding openjpeg.h since it should be looking in
> /usr/include/openjpeg/ ...

Actually, openjpeg package should be fixed to install the header in /usr/include instead, see bug 484887.
Comment 5 Moritz Barsnick 2009-03-18 14:06:53 EDT
Regarding comment #2:

Without pkg-config, I guess it's up to the app to guess/know what dependencies a linked library has. This is especially valid for linking against a static lib.

With a dynamic lib, the dependency can be forced with a simple "-lm" at link time though. :-)

I'm new at CMake, but I think I figured it out. A patch is attached. It "works for me". Poppler-0.10.5 now correctly detects openjpeg.
Comment 6 Moritz Barsnick 2009-03-18 14:09:05 EDT
Created attachment 335746 [details]
patch to force libm dependency at build

This patch makes CMake add a build/link time dependency on libmath (libm), which is thus properly exposed to other applications trying to link agains libopenjpeg without "-lm".
Comment 7 Moritz Barsnick 2009-05-18 07:23:09 EDT
*ping*

Does my attachment in comment #6 not fix the original issue properly? It does for me...
Comment 8 Rex Dieter 2009-06-19 09:22:28 EDT
I've hit this too, I'll take a look at integrating the patch, thanks.
Comment 9 Rex Dieter 2009-06-19 11:00:51 EDT
Fixed in rawhide.
Comment 10 Fedora Update System 2009-06-19 11:18:52 EDT
openjpeg-1.3-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openjpeg-1.3-5.fc11
Comment 11 Fedora Update System 2009-06-19 11:19:36 EDT
openjpeg-1.3-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/openjpeg-1.3-5.fc10
Comment 12 Fedora Update System 2009-06-24 15:20:13 EDT
openjpeg-1.3-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openjpeg'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6882
Comment 13 Fedora Update System 2009-06-24 15:23:57 EDT
openjpeg-1.3-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openjpeg'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6786
Comment 14 Fedora Update System 2009-07-16 02:51:04 EDT
openjpeg-1.3-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2009-07-16 02:53:54 EDT
openjpeg-1.3-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.