Bug 467679 - blkid command does not report swap partition's label in rhel4.7-as-i386
blkid command does not report swap partition's label in rhel4.7-as-i386
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sandeen
BaseOS QE
:
: 460608 466161 (view as bug list)
Depends On:
Blocks: 460608
  Show dependency treegraph
 
Reported: 2008-10-20 03:44 EDT by YangKun
Modified: 2009-05-18 16:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* The blkid command did not report the labels of swap partitions. Some end-users may have found this result surprising and been misled into thinking that there was a problem with the partitioning of the device. Blkid now reports labels of swap partitions, just as it reports the labels of other partitions.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:25:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description YangKun 2008-10-20 03:44:29 EDT
Description of problem:
blkid command does not report swap partition's label in rhel4.7-as-i386


Version-Release number of selected component (if applicable):
[root@dhcp-65-159 ~]# blkid -v
blkid 1.0.0 (12-Feb-2003)


How reproducible:
always


Steps to Reproduce:
1. when installing rhel4.7-as-i386, manually create a swap partition at the partitioning stage, do not use LVM
2. once the installation is done, reboot. check the /etc/fstab, you'll see the swap partition was assigned a "LABEL" by the system by default
3. run the command "blkid", you'll see the swap partition's "LABEL" information is missing from blkid's output


Actual results:
[root@dhcp-65-159 ~]# cat /etc/fstab 
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/                 /                       ext3    defaults        1 1
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
LABEL=SWAP-hda3         swap                    swap    defaults        0 0
/dev/hdc                /media/cdrom            auto    pamconsole,fscontext=system_u:object_r:removable_t,exec,noauto,managed 0 0
[root@dhcp-65-159 ~]# blkid 
/dev/hda1: LABEL="/boot" UUID="5c16b1bc-a381-4f3b-8956-c4a2bc468802" SEC_TYPE="ext3" TYPE="ext2" 
/dev/hda2: LABEL="/" UUID="6f7b3f46-d36a-4bb2-9b73-5a09ba0d16f4" SEC_TYPE="ext3" TYPE="ext2" 
/dev/hda3: TYPE="swap" 
[root@dhcp-65-159 ~]# uname -a
Linux dhcp-65-159.nay.redhat.com 2.6.9-78.EL #1 Wed Jul 9 15:27:01 EDT 2008 i686 i686 i386 GNU/Linux
[root@dhcp-65-159 ~]#


Expected results:
the blkid command should report the swap partition's label information.


Additional info:
1) blkid does report the label information for ext3 partitions in rhel4.7
2) blkid does report the swap partition's label information in rhel5.2
Comment 1 Eric Sandeen 2008-11-06 15:12:00 EST
We'd need this change, and later fixes, to support this:

commit 7369f0ce5fdde7f8a1cc6e49211469b905c2c58f
Author: Theodore Ts'o <tytso@mit.edu>
Date:   Mon Jan 10 23:58:11 2005 -0500

    Apply Janos Farkas's patch to support extracting the uuid and label
    information from swap partitions.
    
    Also make sure that if a partition has a label removed, that the label is
    removed form the blkid cache as well.
    
    Add support for detecting 32k and 64k pagesize swap files.

However, at this late stage in RHEL4, this sounds like a feature request, and I'm not certain that we should invest the effort.  Is there a pressing need for this feature?

Thanks,
-Eric
Comment 2 YangKun 2008-11-06 21:51:19 EST
*** Bug 460608 has been marked as a duplicate of this bug. ***
Comment 3 YangKun 2008-11-06 21:56:34 EST
Fujitsu engineers found this bug while doing the hardware certification work. It's not a blocker, but we hope this bug can be fixed.

Thanks
-YK
Comment 4 Eric Sandeen 2008-12-02 15:24:55 EST
This may be technially a feature request, but it's a small simple one; an upstream backport.  It looks like it's interfering with some certification tests (see bug 460608).
Comment 5 YangKun 2008-12-02 21:35:16 EST
*** Bug 466161 has been marked as a duplicate of this bug. ***
Comment 8 Eric Sandeen 2008-12-04 12:28:00 EST
Committed in e2fsprogs-1.35-12.20.el4, actually built in e2fsprogs-1.35-12.21.el4
Comment 10 Ruediger Landmann 2009-01-27 23:56:52 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
* The blkid command did not report the labels of swap partitions. Some end-users may have found this result surprising and been misled into thinking that there was a problem with the partitioning of the device. Blkid now reports labels of swap partitions, just as it reports the labels of other partitions.
Comment 13 errata-xmlrpc 2009-05-18 16:25:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0996.html

Note You need to log in before you can comment on or make changes to this bug.