Bug 467699 - GDM doesn't recognize system-wide keyboard setting
GDM doesn't recognize system-wide keyboard setting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 07:22 EDT by Corentin Perard-Gayot
Modified: 2015-01-14 18:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 12:38:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corentin Perard-Gayot 2008-10-20 07:22:08 EDT
Description of problem:
I installed 10 beta from the live medium. I chose french keyboard layout. Once installed, I re-booted the computer and ended up in front of GDM, that would propose me USA as the default keyboard. I of course changed it to french, but it seems the keyboard layout settings is still not respected. If I create a new user on the system, its default keyboard layout in gdm will be USA.

Version-Release number of selected component (if applicable):
at the moment : 2.24.0-10, but in fact I don't really know because I updated the gdm package since it was installed. 

How reproducible:
always

Steps to Reproduce:
install from the live medium, choose french layout, reboot, and see GDM not accepting default layout.
  
Actual results:
default keyboard after install is USA

Expected results:
default keyboard respecting system-wide keyboard layout setting defined by user's selection in the installer

Additional info:
I haven't got any xorg.conf file, nor do I have a /etc/X11/Xkbmap file. (by the way, how is keyboard layout for X detected then ?)
Comment 1 Matthias Clasen 2008-10-20 12:38:30 EDT
I've fixed this in 2.24.0-11, I hope.

Note You need to log in before you can comment on or make changes to this bug.