Bug 46771 - nfs Client fileHandle cache updation is not consistent.
nfs Client fileHandle cache updation is not consistent.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Steve Dickson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-30 07:26 EDT by Madhan
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-15 16:05:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Madhan 2001-06-30 07:26:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
RedHat 7.1 (fine with 6.2 and 7.0) even after getting an updated NFS 
Handle from NFS Server in a lookup call, Linux NFS Client issues, calls 
with old NFS Handle, which fails.

How reproducible:
Always

Steps to Reproduce:
*. Works fine with RedHat 6.2 and 7.0, but fails in 7.1
*. Against Netware NFS Server, exporting an NSS Volume

1. touch a
2. mv a b
3. link b c (or) cat b 

Actual Results:  Gives an I/O Error in either case.

Expected Results:  Step 3 should create a hardlink c to b (or) display 
content of b

Additional info:

* Say fileHandle of 'a' is fh1
* During mv, rename operation 'a' to 'b' is successful. (But NetWare NFS 
Server changes the fileHandle of 'b' to fh2)
* Linux NFS Client now issues a Lookup for 'b' and gets the new fileHandle 
fh2 (EXPECTING Linux NFS client to update it's fileHandle cache, at this 
point)
* Now during linking or reading, instead of issuing NFS Calls with updated 
fh2 handle, NFS Calls are issued with fh1, leading to the I/O error, as 
the handle may not always be valid now at the NFS Server.

Will attach or send the snoop traces soon or when asked for.  Contact 
PMadhan@yahoo.com
Comment 1 Madhan 2001-07-05 05:13:03 EDT
Changed priority and severity as basic operations like fail due to this, 
against the NFS Server.
Comment 2 Steve Dickson 2004-07-15 16:05:19 EDT
Please Upgrade to supported Release

Note You need to log in before you can comment on or make changes to this bug.