Bug 467715 - Clicking the "delete user" link in user -> Notification Methods leads to 404 Error - File Not Found
Clicking the "delete user" link in user -> Notification Methods leads to 404 ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
520
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Michael Mráka
/network/users/details/contact_method...
:
: 469909 (view as bug list)
Depends On:
Blocks: 463877
  Show dependency treegraph
 
Reported: 2008-10-20 09:49 EDT by Jan Pazdziora
Modified: 2009-09-10 14:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:49:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2008-10-20 09:49:10 EDT
Description of problem:

User's Notification Methods page is at /network/users/details/contact_methods/index.pxt
(for example https://xen83.englab.brq.redhat.com/network/users/details/contact_methods/index.pxt?uid=22) and at the top of the page there is a "delete user" link.

Clicking that link leads to /network/users/details/delete_confirm.pxt (for example https://xen83.englab.brq.redhat.com/network/users/details/delete_confirm.pxt?uid=22)
which does not seem to exist.

Version-Release number of selected component (if applicable):

# rpm -q rhns
rhns-5.2.0-15.el5

How reproducible:

Deterministic.

Steps to Reproduce:
1. Click on Users, select user, click on Notification Methods.
2. You'll get to .../network/users/details/contact_methods/index.pxt?uid=...
3. Click the "delete user" link.
  
Actual results:

.../network/users/details/delete_confirm.pxt?uid=...

404 Error - File Not Found

The requested page can not be found.

Please report this error to your local administrator.

Expected results:

Something like

  Confirm User Deletion
  This will delete this user permanently.

Additional info:

All the other User's pages have the "delete user" link pointing to (presumably existing) .../rhn/users/DeleteUser.do?uid=... page. The Notification Methods page should probably use that URL as well.
Comment 1 Shannon Hughes 2008-11-19 14:29:57 EST
fixed in sw0.4 and sat530
Comment 2 Jesus M. Rodriguez 2008-11-25 15:01:07 EST
*** Bug 469909 has been marked as a duplicate of this bug. ***
Comment 3 Michael Mráka 2009-03-16 06:30:01 EDT
Verified. Satellite-5.3.0-RHEL5-re20090306.2

Link points to /rhn/users/DeleteUser.do?uid=... and works.
Comment 4 Tomas Lestach 2009-09-07 05:12:10 EDT
"delete user" link on https://<satellite>/network/users/details/contact_methods/index.pxt?uid=<uid> page leads to https://<satellite>/rhn/users/DeleteUser.do?uid=<uid>

User deleted successfully.

Stage validated -> RELEASE_PENDING
Comment 5 Brandon Perkins 2009-09-10 14:49:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.